Any VBScript Experts out there?

Reply
L4 Transporter

Any VBScript Experts out there?

We're working on a Aruba VIA VPN project, and I want to use the Palo Alto User-ID API to record the usernames of the logged in users without having them go through the captive portal.

This document looks like it would work really well for my purpose () but there is a slight problem. These computers will more than likely not be joined to the domain. So this line:

strXMLLine = strXMLLine & "<entry name=""" & WshNetwork.UserDomain & "\" & WshNetwork.UserName & """ ip=""" &      IPConfig.IPAddress(i) & """/>"

really won't work for me. Is there anyway to call a pop-up box, have the user enter their username, and then pass that username as a variable instead of "WshNetwork.UserName?"

Tags (2)
L2 Linker

Re: Any VBScript Experts out there?

While you can add that to the script it would not be ideal, as we are not authenticating the user in that script, so they could type any name that wanted into the box and get mapped to them. Is your Aruba deployment using Enterprise WPA or some form of 802.1x authentication? If so you may find this document useful

Nick

L4 Transporter

Re: Any VBScript Experts out there?

They are actually getting authenticated by the Aruba VIA VPN client with an RSA SecurID Token.

L2 Linker

Re: Any VBScript Experts out there?

What do the Aruba logs look like? If you can just pull the syslog from it you may have your problem solved.

I have seen ones similar to this:

522008: |authmgr| User authenticated: Name=TESTDOMAIN\ssmith MAC=00:19:7e:66:93:e3 IP=192.168.198.3 method=802.1x server=IAS-Radius1 role=testdomain-employee


L4 Transporter

Re: Any VBScript Experts out there?

I was able to get it to work using the Syslog integration.

The Aruba log looked like this:

12-14-2011     11:58:54          Local1.Notice aruba.local   Dec 14 13:58:54 aruba.local authmgr[1527]: <522008> <NOTI> <aruba.local 127.0.0.1>  User Authentication Successful: username=USERNAME MAC=00:00:00:00:00:00 IP=X.X.X.X role=vpn-user VLAN=1 AP=N/A SSID=N/A AAA profile= auth method=VIA-VPN auth server=N/A

I filtered in Kiwi using the message text "User Authentication Successful"

I did have to add our domain to the script.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!