Error Generating API Key on PA-2020 with PAN 4.1.7

Reply
Not applicable

Error Generating API Key on PA-2020 with PAN 4.1.7

I am trying to generate an API key on a PA-2020 running software version 4.1.7.

I have tried using the default admin user and also an admin user with read-only access specifically created for API.

in both cases i get the message:

<response status="error">

<result>

<msg>

Authentication failed: Invalid username or password

</msg>

</result>

</response>


the command i am using to generate the key is https://hostname/api/?type=keygen&user=username&password=password


thanks.

SRA
L4 Transporter

Re: Error Generating API Key on PA-2020 with PAN 4.1.7

are you able to login to the firewall WebUI with those same credentials?

Not applicable

Re: Error Generating API Key on PA-2020 with PAN 4.1.7

i am able to logon directly via the WebUI on the firewall and access the dashboard with these same credentials

L3 Networker

Re: Error Generating API Key on PA-2020 with PAN 4.1.7

you can run:

> tail follow yes mp-log authd.log

and try your request to see if there is any information that may show the issue.

ms.log, php.debug.log and appWeb.log can also have useful information when debugging API usage.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!