Unable to run software download via ansible.

L1 Bithead

Unable to run software download via ansible.



I'm working on automating software updates via ansible and having a key issue with the excution of the download command using the panos_op module. 


I've been able to exceute "request system software check" to grab the latest avaialble software, but when i run the "request system software download version #.#.#"  it errors with     "msg": "URLError: code: 400 reason: Bad Request"


I have confirmed that the version i'm trying to download is listed, and i confirmed that if i run the command on the unit itself it works -  it only fails when trying to exceute via ansible. 


Heere is the output form the debug : I can confirm 8.1.0 is installed, and 8.1.2 is listed after running "request system software check" 


Log output

fatal: [localhost]: FAILED! => {

    "changed": false,

    "invocation": {

        "module_args": {

            "api_key": null,

            "cmd": "request system software download version 8.1.2",

            "ip_address": "",

            "password": "VALUE_SPECIFIED_IN_NO_LOG_PARAMETER",

            "username": "ansible-agent"



    "msg": "URLError: code: 400 reason: Bad Request"


        to retry, use: --limit @/home/baismanage/ansible/download_sw.retry





L1 Bithead

Re: Unable to run software download via ansible.

reolved this when i noted the panos_software module which handles upgrades. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!