BUG: Source zone is removed when editing a security policy

Highlighted
L1 Bithead

BUG: Source zone is removed when editing a security policy

Hi all,

 

Using version 1.1.1. I noticed that when I am editing a security policy it will usually remove one of the source security zones. It appears that if there is more than one source zone this happens, not if there is a single zone listed.

 

Can someone else confirm?


Thanks!

 

 

L3 Networker

Re: BUG: Source zone is removed when editing a security policy

Was it an ASA Import?

L4 Transporter

Re: BUG: Source zone is removed when editing a security policy

Are you using a Panorama configuration? I am seeing similar behavior in Panorama configurations that have templates, but the templates do not have any interfaces or virtual router configurations. Can you check if your configuration file is a Panorama configuration and has templates with no interfaces and virtual router configurations?

 

Fyi, I am not seeing this behavior with Panorama configurations that have templates with interface and virtual router configurations.

L4 Transporter

Re: BUG: Source zone is removed when editing a security policy

Are you sure it deletes them?

Could it be that it presents them in a different order?

I tried to replicate the issue, but I did not have this behavior that you mention.

L3 Networker

Re: BUG: Source zone is removed when editing a security policy

I couldn't replicate it either.

 

I've seen this happen when I tried to edit a bunch of rules and Expedition was still processing it and I made a change.  I lost 900+ source zones.  I learned to wait for Expedition to process the multi-edit selection.

 

I too noticed (and reported it to this community) that the rules are not being ported in order as they are in the ASA.

 

Bob

L4 Transporter

Re: BUG: Source zone is removed when editing a security policy

Thanks for reporting.

 

We finally found the reason and it will get resolved in the next update.

 

There was a UI issue that would miss reading some zones if the back-end would take to long to respond with them.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!