Reply
L1 Bithead
Posts: 9
Registered: ‎04-19-2012

Re: Best Practices Analysis Not Running

It's working now with update 1.0.92 and the python update.

 

Thanks!

L0 Member
Posts: 2
Registered: ‎08-08-2018

Re: Best Practices Analysis Not Running

Any news about the new repo ?

 

Still having the following ssue in 2018 :

  

expedition@Expedition:~$ sudo apt-get update
...
Reading package lists... Done
W: The repository 'https://conversionupdates.paloaltonetworks.com expedition-updates/ Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
expedition@Expedition:~$
L0 Member
Posts: 1
Registered: ‎08-31-2018

Re: Best Practices Analysis Not Running

I'm not seeing any results in the BPA. I've tried with a Panorama XML as well as a running config from a connected device. The progress bar goes to "Done!" and I don't get any results.

 

Expedition version 1.0.103

BPA version is not showing anything

 

I've run apt-get update and install and still no luck.

L7 Applicator
Posts: 908
Registered: ‎03-22-2011

Re: Best Practices Analysis Not Running

Do you remember if after any expedition update you followed this instructions?

 

sudo bash /var/www/html/OS/BPA/updateBPA306.sh

Try to runnit from the cli if not.

L0 Member
Posts: 1
Registered: ‎06-13-2018

Re: Best Practices Analysis Not Running

I was able to get this running. I did the follwing:

 

expedition@Expedition:~$ sudo apt-get update

And I looked in the directory previously mentioned and found a zip:

expedition@Expedition:~$ cd /var/www/html/OS/BPA/
expedition@Expedition:/var/www/html/OS/BPA$ ls
best_practice_assessment_ngfw_pano-master.zip

So I unzipped it:

expedition@Expedition:/var/www/html/OS/BPA$ sudo unzip best_practice_assessment_ngfw_pano-master.zip 

Then cd to the directory and see the files:

expedition@Expedition:/var/www/html/OS/BPA$ cd best_practice_assessment_ngfw_pano-master/
expedition@Expedition:/var/www/html/OS/BPA/best_practice_assessment_ngfw_pano-master$ ls
best_practice_assessment_ngfw_pano  Dockerfile.test  pytest.ini  requirements.txt  test-requirements.txt
build.sh                            MANIFEST.in      README.md   setup.py          VERSION

I read the README file and followed the "Clone method". Which is to use the pip command to install.  I ran the following commands:

 

expedition@Expedition:/var/www/html/OS/BPA/best_practice_assessment_ngfw_pano-master$ 

cat README.md 
pip install -r requirements.txt
###  a message warned me that I needed to upgrade pip
sudo pip install --upgrade pip
sudo pip install -e .

I went to the web UI and hit refresh and BAM! It worked.

 

I assumed this feature would be enabled by default, but I installed this in Fusion on my laptop and in the customer's environment after converting it with the VMware converter - both installs had the issue of not displaying BPA results after running the analysis. 

 

I hope this helps.

 

Chris

Highlighted
L1 Bithead
Posts: 3
Registered: ‎02-22-2017

Re: Best Practices Analysis Not Running

Thanks for the guide. Worked for me. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!