Cannot add device PAN-OS 9.0

Reply
L2 Linker

Cannot add device PAN-OS 9.0

Hello to all,

 

I am doing a migration of PA-820 on version 9.0 as a device. However, when adding the username and password it gives me a remote exception error.. I can ping the management interface from the firewall to expedition and vice versa. I also tried using the API key, I generated it and add it. However, when I click retrieve contents, it did not retrieve any file (expedition agent is up).  The user is a super user local admin on the FW.

 

1- Where I can see the log of the possible error?? (complete linux path please - will like to see a guide about this)

2- Is there a limitation of Expedition for version 9.0 of adding it as a device? I haave another firewall in PAN-OS 8.1 added. I upgrade it to 9.0 and I was able to retrieve the contents (already had the API key in 8.1). Also, I am able to import the  XML of 9.0 without any problems.

3- Please advise on how ti fix. I saw other posts about this, but they said just to upgrade. Will do that if I have time.

 

Expedition version: 1.1.10

PA8-820 version: 9.0

 

@alestevez Please take a look to the post.

 

In the meantime, I am importing / exporting the XML file, however this is slowing a bit my migration process..

 

image.png

 

image.pngAPI keys addedimage.pngNo info retrieved

L7 Applicator

Re: Cannot add device PAN-OS 9.0

Hi, you are right. In Expedition and for backward compatibility between version we were using the old API calls under the path:

 

/esp/restapi.esp

 

In Panos 9.0 this way to call the API has been deprecated so now we are updating Expedition to use the current API Path

 

/api

 

Next version 1.1.12 will come with the hotfix.

L2 Linker

Re: Cannot add device PAN-OS 9.0

Thanks! When the version 1.11.12 will be available?

Highlighted
L2 Linker

Re: Cannot add device PAN-OS 9.0

already :)

it seems they've kept the promise.

Expecting release notes soon :)

L2 Linker

Re: Cannot add device PAN-OS 9.0

Yep, configured some days ago and its working :)

L0 Member

Re: Cannot add device PAN-OS 9.0

No working for me.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!