Getting Error upgrading Expedition

Reply
L2 Linker

Getting Error upgrading Expedition

We are on version 1.1.14 and need to get Expedition current but am getting the following errors when trying to upgrade from CLI:

 

expedition@Expedition:~$ sudo apt-get update
Get:2 http://sgp1.mirrors.digitalocean.com/mariadb/repo/10.1/ubuntu xenial InRelease [4,597 B]
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:6 http://ppa.launchpad.net/adiscon/v8-stable/ubuntu xenial InRelease
Get:7 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Hit:1 https://www.rabbitmq.com/debian testing InRelease
Hit:8 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial InRelease
Ign:9 https://conversionupdates.paloaltonetworks.com expedition-updates/ InRelease
Ign:10 https://conversionupdates.paloaltonetworks.com expedition-updates/ Release
Ign:11 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages.diff/Index
Ign:12 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en_US
Ign:13 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en
Ign:14 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages
Ign:12 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en_US
Ign:13 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en
Ign:14 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages
Ign:12 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en_US
Ign:13 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en
Ign:14 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages
Ign:12 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en_US
Ign:13 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en
Get:14 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages [595 B]
Ign:14 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages
Ign:12 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en_US
Ign:13 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en
Ign:14 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages
Ign:12 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en_US
Ign:13 https://conversionupdates.paloaltonetworks.com expedition-updates/ Translation-en
Err:14 https://conversionupdates.paloaltonetworks.com expedition-updates/ Packages
Could not open file /var/lib/apt/lists/partial/conversionupdates.paloaltonetworks.com_expedition-updates_Packages.gz - open (13: Permission denied)
Fetched 114 kB in 1s (57.0 kB/s)
Reading package lists... Done
W: The repository 'https://conversionupdates.paloaltonetworks.com expedition-updates/ Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://conversionupdates.paloaltonetworks.com/expedition-updates/Packages Could not open file /var/lib/apt/lists/partial/conversionupdates.paloaltonetworks.com_expedition-updates_Packages.gz - open (13: Permission denied)
E: Some index files failed to download. They have been ignored, or old ones used instead.
expedition@Expedition:~$
expedition@Expedition:~$ sudo apt-get install expedition-beta
Reading package lists... Done
Building dependency tree
Reading state information... Done
expedition-beta is already the newest version (1.1.14).
The following packages were automatically installed and are no longer required:
linux-headers-4.4.0-134 linux-headers-4.4.0-134-generic linux-image-4.4.0-134-generic linux-image-extra-4.4.0-134-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 130 not upgraded.

 

Please advise

L4 Transporter

Re: Getting Error upgrading Expedition

Could it be that you have duplicated repos in your APT list in Expedition?

 

As it is complaining about the partial, you can safely delete the files there:

 

rm /var/lib/apt/lists/partial/*

 and try again

 

Do it with root rights, or via "sudo" 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!