If You Need an OVA...

Reply
L1 Bithead

Re: If You Need an OVA...

Cannot deploy official OVA.

VMware ESXi, 6.0.0, 9239799

Issues detected with selected template. Details: - -1:-1:VALUE_ILLEGAL: No supported hardware versions among [vmx-12]; supported: [vmx-04, vmx-07, vmx-08, vmx-09, vmx-10, vmx-11].

L1 Bithead

Re: If You Need an OVA...

seems that the official OVA was built for virtual hardware version 12 or higher since the ovf file has

"<vssd:VirtualSystemType>vmx-12</vssd:VirtualSystemType>" 

see KB article https://kb.vmware.com/s/article/1003746

 

ESX 6.0 is still supported by VMWare until March 12th, 2020 

see VMWare announcment: https://www.vmware.com/content/dam/digitalmarketing/vmware/en/pdf/support/product-lifecycle-matrix.p... 

L4 Transporter

Re: If You Need an OVA...

I have seen this issue/message with installations of ESXi on older server hardware that was not compatible with the vmx-12 drivers.

 

i'll see what can options there are to support this.

 

L0 Member

Re: If You Need an OVA...

Is https://paloaltonetworks.box.com/s/davuvo65k727nm7feuug0d783zo6fjx8 the latest download for the tool? I've been searching around the site for 20 minutes now and this is the only link I can find to download expedition.

 

There was a post on 4/15 from sjanita saying there is a link for "Get the tool OVA" on https://live.paloaltonetworks.com/t5/Expedition-Migration-Tool/ct-p/migration_tool but that just takes me to a listing of the expedition forums.

 

Thanks

L1 Bithead

Re: If You Need an OVA...

It seems like the new landing page has no simple "get the tool" button. I think it is temporary until they redesign the page and make a simpler way to download. but for now if the download link works for you; use it and update to the latest build.

L1 Bithead

Re: If You Need an OVA...

As the creator of this thread, and the unofficial OVA's, you really should use the official OVA now available by the Expedition team. That being said, I am still updating my OVA for my team since I needed to support older VM instances and the OS/Expedition would be current upon instantiation. I will be moving them to S3 soon as I no longer have access to box. I will update the links once they are moved to their new home. 

Again, not supported or recommended since there are official images now.

L4 Transporter

Re: If You Need an OVA...

Hi guys,

 

You are right that the dowload link was .not available for a while. But it is back now.

 

Also, I have some extra good news to bring you. We have created a installer Script that would set up an Expedition instance on a newly clean Ubuntu 16.04 Server VM.

So, there should be no issues for you to create a new image with your VMWare restrictions and, on that, run the script to get all the services requried for Expedition.

If everything goes smooth, we will post a message with the instructions during next week.

 

Highlighted
L0 Member

Re: If You Need an OVA...

Hey Didac,

 

Do you know when this will be available?

L4 Transporter

Re: If You Need an OVA...

Hi guys,

 

I forgot about you in his thread.

Well, the script is already available, and you may not know, but you already have it if you downloaded an Expedition update recently.

 

We will make the script also available to download by itself, of course.

 

So, the script is in

/var/www/html/OS/installer

 

You will find in that folder two files. One is initSetup.sh. The second is databases.tgz

You need them both.

 

  1. Download an Ubuntu 16.04 server (http://releases.ubuntu.com/16.04/) and install it as normal.
  2. Once installed, upload the two files initSetup.sh and databases.tgz via scp, or wget into the same folder in your new Ubuntu server machine
  3. change permit to initSetup.sh via the command "sudo chmod 755 initSetup.sh"
  4. execute the initSetup.sh as root: "sudo ./initSetup.sh"
  5. let the script handle it all for you. It will update configurations, download packages, install them, set them up and modify settings for Expedition. Even create users for database connections. It only requires the Ubuntu 16.04 machine and Internet connection.

Enjoy!

 

L1 Bithead

Re: If You Need an OVA...

error.jpg

Don't seem the script finishes successfully.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!