error when adding device

Reply
Highlighted
L3 Networker

error when adding device

When adding a device I receive an empty error message in the UI as shown belowScreen Shot 2018-06-20 at 17.15.49.png

 

In the Apache error.log I see the following message appear:

 

PHP Fatal error:  Uncaught PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'avoidToday' in 'field list' in /var/www/html/libs/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:77\nStack trace:\n#0 /var/www/html/libs/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(77): PDO->prepare('insert into `de...', Array)\n#1 /var/www/html/libs/vendor/illuminate/database/Connection.php(452): Doctrine\\DBAL\\Driver\\PDOConnection->prepare('insert into `de...')\n#2 /var/www/html/libs/vendor/illuminate/database/Connection.php(657): Illuminate\\Database\\Connection->Illuminate\\Database\\{closure}('insert into `de...', Array)\n#3 /var/www/html/libs/vendor/illuminate/database/Connection.php(624): Illuminate\\Database\\Connection->runQueryCallback('insert into `de...', Array, Object(Closure))\n#4 /var/www/html/libs/vendor/illuminate/database/Connection.php(459): Illuminate\\Database\\Connection->run('insert into `de...', Array, Object(Closure))\n#5 /var/www/html/libs/vendor/illuminate/database/Connection.php(411) in /var/www/html/libs/vendor/illuminate/database/Connection.php on line 664, referer: https://172.16.11.129/

 

Is this a known issue for the 1.0.90 build? The only "strange" thing about the device is that it's accessible on a different port than 443.

L2 Linker

Re: error when adding device

That is a bug with 1.0.90, 1.0.91 appears to have fixed it 

L0 Member

Re: error when adding device

Same exact issue here, running 1.0.91

L7 Applicator

Re: error when adding device

Hi, That's is weird, after the upgrade there is a script that updates the tables on the databases. Please can you try to run the command from the cli and see the output?

 

sudo php /var/www/html/bin/updates/updateSQL.php
L0 Member

Re: error when adding device

I was having the same error as above until I manually ran the PHP script you linked.  I'm running 1.0.92.

L0 Member

Re: error when adding device

That script did it for me, as well. Thanks!

L1 Bithead

Re: error when adding device

I have this issue on 1.0.107 .  Running the sudo php /var/www/html/bin/updates/updateSQL.php made no difference. Any ideas?

 

L7 Applicator

Re: error when adding device

Maybe did you UPGRADE the OS? with something like "apt-get updagre" ?

 

If yes you should downgrade it or download it again and dont use the Upgrade or dist-upgrade commands, just use 

 

sudo apt-get update
sudo apt-get install expedition-beta

There is something in newer version of the packages in the new OS version that breaks expedition so keep it in 16.04 dont upgrade to 18.04

L0 Member

Re: error when adding device

my expedition 1.1.17 and i found this error after upgrade and try to sudo apt-get dist-upgrade but result its still error.

try to sudo php /var/www/html/bin/updates/updateSQL.php and the result PHP FATAL ERROR not found /var/www/html/bin/updates/updateSQL.php

 

anyone have another solution?

 

 

L4 Transporter

Re: error when adding device

It is in the documentation that we should perform "apt-get update" but do not perform "upgrade", as it will break Expedition dependencies by updating some packages that have modified their internal APIs.

 

I am sorry to say, but you may have to collect a new Expedition VM.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!