Captive Portal doesn't redirect

Reply
Highlighted
L4 Transporter

Captive Portal doesn't redirect

Hi Community,

 

I'm getting mad....

I configured a simple captive portal in my testing environment with saysing: everything from host A to untrust with tcp-443 and tcp-80 will be captive-portaled - so far so good.

I configured the captive-portal in the user-id area, did the interface profile settings, activated the user-id on the zones and configured a transparent proxy.

 

When I try to access a website, I'm getting redirected to captive portal, I can enter my credentials.
The credentials are valid, you can see that in the authentication log, but the captive portal page just performs a refresh.

 

I can see, that there is a user-id entry with type CP in the system, but I cannot access any http-sites at all, because the captive portal page won't go away.

https isn't working - but that's not the problem for now, I just want to get it work with http first.

I tested it with chrome, firefox and internet explorer, so I assume there is no browser related issue.

I'm using PAN-OS 8.1.0.

 

Does anybody has an idea what else to test/check?

Maybe I'm missing something obvious?

 

Best Regards

Chacko42

Tags (3)
Community Manager

Re: Captive Portal doesn't redirect

hi @Chacko42

 

I'm not aware of any limitations, but if this is the case you'll want to inform TAC to have this reported to engineering and fixed

 

on a side note, are you having your users log on with user@domain.ext usernames?

the auth profile can be set to add the suffix for you, so users can simply input their username:

 

ldap suffix.png

 

this may give you some additional characters until the underlying issue is addressed


Help the community: Like helpful comments and mark solutions
Reaper out
L4 Transporter

Re: Captive Portal doesn't redirect

Hi @reaper,

 

as an authentication profile I'm recycling a existing Radius profile, LDAP is not in use.

I will have another look on this issue next week with my colleagues - if we find something out I will post it here, otherwise we will open a ticket to see where the problem is.

 

Thanks

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!