Captive portal users not in groups?

Reply
Not applicable

Captive portal users not in groups?

We are using the UserID agents on our servers for ID and groups.  Users that login via our AD domain on bound machines are correctly identified and we can apply policies based on group membership.  That all works very nicely.  We just put captive portal in place that uses Kerberos for authentication against AD.  Users are authenticated, but policies that are based on group membership are not applied. Is there a disconnect between the two sources that keeps the groups from applying to users that are authenticated via captive portal?

Tags (2)
Not applicable

Re: Captive portal users not in groups?

For Kerberos, you need to create a user-group in the Local Database on the Palo Alto.

Highlighted
Not applicable

Re: Captive portal users not in groups?

What I ended up doing was restricting the authentication profile for captive portal to specific groups, and that seems to make sure they ended up with the group memberships.  It was a better solution than I expected because it also restricted the captive portal use to only accounts that were people.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!