Correct IP setting when two firewalls connected to one ISP.

Reply
L4 Transporter

Correct IP setting when two firewalls connected to one ISP.

We have two PA's connecting to one ISP. One is just being set up.

 

The ISP is "10.10.10.0/27"

Route is "10.10.10.5"

 

Is it correct to have both firewall external vlan interfaces as such

 

FW1 "10.10.10.99/27"

FW2 "10.10.10.122/27"

 Vlan 140

 

Vlan.jpg

 

 

 

And for the NAT

 

NAT.jpg

 

 

FW1 Main Nat "10.10.10.99/27"

FW2 Main Nat "10.10.10.122/27"

 

 

 

 

I ask, because the new firewall is logging packets for the old firewall. I am seeing "x.x.x.99" on the firewall with VIP "x.x.x.122"

 

monitor.jpg

 

 

 

Tags (2)
Community Manager

Re: Correct IP setting when two firewalls connected to one ISP.

- If your ISP's subnet is 10.10.10.0/27 , you have usable IP addresses 10.10.10.1 to 10.10.10.30, so your firewalls would need to have an IP in that range

- your vlans are untagged, you'll want to tag them and use proper vlans on your switches to prevent having one giant, and insecure broadcast domain

 

are there any other nat rules? it's possible your old firewall has taken ownership of all the IP's in that subnet if there's a NAT policy that allows it


Help the community: Like helpful comments and mark solutions
Reaper out
L4 Transporter

Re: Correct IP setting when two firewalls connected to one ISP.

The IP's were just an obscured example.

 

Both have the same "/27"  on the interface and is that correct? 

Neither firewall has overlapping NAT IP addresses. the NAT addresses are x.x.x.y/27

 

 

I have the VLANS tagged on the aggregate interface, I assume that is sufficient and does not need tagged on the VLAN aswell. The switches are VLANED.

 

ae2.jpg

 

 

 

 

Highlighted
L4 Transporter

Re: Correct IP setting when two firewalls connected to one ISP.

It all seems to be working,

 

It's just the loggs showing IP's from the other firewall that are the concern.  There's a 3rd Device on that subnet that also connects to the ISP, I don't see it at all in the loggs.

 

 

L7 Applicator

Re: Correct IP setting when two firewalls connected to one ISP.

Hello,

Are you running active/passive or active/active? A/P doesnt need an IP for each firewall as they are shared between the two.

 

Regards,

L4 Transporter

Re: Correct IP setting when two firewalls connected to one ISP.

Two independant firewall HA stacks, one ISP Subnet.

L7 Applicator

Re: Correct IP setting when two firewalls connected to one ISP.

Hello,

My guess is that you have a policy somewhere that allows the 'untrust' zone to 'untrust' zone traffic and its set to log. This will catch any traffic that the interface picks up on.

 

Regards,

L4 Transporter

Re: Correct IP setting when two firewalls connected to one ISP.

"Intrazone-Default" is set to log as per Palo Best Practice.

 

I will stop worrying about it as I thought the configuration was correct and there are no issues.

L4 Transporter

Re: Correct IP setting when two firewalls connected to one ISP.

May I ask why you are using VLAN interfaces to begin with?  I avoid this if at all possbile.  I would recommend using sub-interfaces at Layer 3.  It is easier to manage, easier to read and makes your zone/ruleset clean.  If you're not transporting Layer 2 traffic through the firewall, VLAN interfaces are almost unnecessary.  Thoughts?

 

Lab Example - 

 

subinterfacesPANexample.PNG

L4 Transporter

Re: Correct IP setting when two firewalls connected to one ISP.

TBH never realy thought about it too much, It was how our original firewall was configured and how I have built things in the test labs. Can't even reember how we did it during the training course.

 

I can see it's a bit cleaner having converted it all over.

 

Not even sure why I did not twig it was a possibility as I am running a L3 single interface at the moment to the outside world

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!