OpenSSL Heartbleed bug: CVE-2014-0160

Reply
L4 Transporter

Re: OpenSSL Heartbleed bug: CVE-2014-0160

Has anyone actually gotten hit by  heartbleed? If so how does it show in the PA etc.

L1 Bithead

Re: OpenSSL Heartbleed bug: CVE-2014-0160

Is this it?

Threat/Content Name   OpenSSL TLS Heartbeat Information Disclosure Vulnerability

L7 Applicator

Re: OpenSSL Heartbleed bug: CVE-2014-0160

IPS vulnerability signature ID 36416 ("OpenSSL TLS Heartbeat Information Disclosure Vulnerability")

L1 Bithead

Re: OpenSSL Heartbleed bug: CVE-2014-0160

I think you guys were searching for the wrong thing.  It was there all along :smileyhappy:

OpenSSL TLS Heartbeat Information Disclosure Vulnerability

36416

OpenSSL is prone to a information leak vulnerability while parsing certain crafted SSL requests. The vulnerability is due to the TLS heartbeat extension failing to properly handle SSL request. An attacker could exploit the vulnerability by sending many crafted SSL requests. A successful attack could lead to leak of the server sensitive information.

CVE-2014-0160

Not applicable

Re: OpenSSL Heartbleed bug: CVE-2014-0160

Me neither.

For good measure, I deleted the existing Threat Definitions and pulled down new ones as I thought perhaps I had originally installed the version that had been pulled by engineering.

Still can't get it to recognize threat hits.

Will this signature/SSL Decoder only work in a situation where the PA is performing decryption?

L4 Transporter

Re: OpenSSL Heartbleed bug: CVE-2014-0160

Is there any way of ensuring you have the correct one?

I logged to the emergency notification this morning and was unable to download on my firewalls (way to go for your content delivery network, Palo Alto, by the way - just fantastic that you send out an emergency noticew via email and then we can't download it), so I downloaded it from the support portal and installed manually - but I don't know how to tell if I have the correct version installed.

L3 Networker

Re: OpenSSL Heartbleed bug: CVE-2014-0160

See the official response linked below:

Why was Emergency 429 Content Briefly Pulled?

To my knowledge, the original file was reposted and there were no changes made.

L4 Transporter

Re: OpenSSL Heartbleed bug: CVE-2014-0160

Fair enough. Thanks.

L7 Applicator

Re: OpenSSL Heartbleed bug: CVE-2014-0160

L4 Transporter

Re: OpenSSL Heartbleed bug: CVE-2014-0160

I have 429-2164 update installed, and I expected to sow in thread logs entries with ( threatid eq 36416) - but I haven't such entries.

I did some verification test by http://possible.lv/tools/hb/ webpage so in my opinion it should appear in thread logs.

Is it normal behaviour?

Regards

Slawek

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!