Problem with user mapping and GlobalProtect connection

Reply
L2 Linker

Problem with user mapping and GlobalProtect connection

Hello!

 

The access to GlobalProtect is done using certificates, it works alright, users are authenticated and identified by sAMAccountName.

 

Sometimes happens that the firewall re-maps the already identified user substituting the sAMAccountName with name.surname, for example. john.smith. I don't understand why.

 

Sometimes it works perfectly, then just moments later you connect again and this re-map happens.

 

Any ideas?

 

Thanks!

 

 

 

 

L7 Applicator

Re: Problem with user mapping and GlobalProtect connection

Hi @Bittereinder ,

 

could it be that sometimes, after the user has authenticated that your user id kicks in an gives the different format.

 

what are you using for cert auth, subject or subject alt.

 

what are you using for user id.

Highlighted
L4 Transporter

Re: Problem with user mapping and GlobalProtect connection

We used sAMAccountName for a couple years without any issues but had to change to userPrincipleName at some point when the GP user-id behavior changed. Might not be related to what you are seeing but reminded me of some changes we had to make after going to 8.1

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!