SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Reply
L4 Transporter

SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hello,

I'm running a cluster of PA (4.0.8) with SSL Decryption configured.

SSL Decryption is not able to decrypt SSL traffic if the HTTPS session is using TLS 1.1 or TLS 1.2.

Test with www.gmail.com   

Chrome : OK (see gmail application in the traffic log)

Firefox : idem

IE 8 or 9 with TLS 1.1 or TLS 1.2 DISABLED : idem

IE 8 or 9 with TLS 1.1 or TLS 1.2 ENABLED : see only SSL application

Is it solved in 4.1.6 (I plan to upgrade my cluster with this release) ??

Regards,

Hedi

L6 Presenter

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Could this be your case ?

According to this PA supports TLSv1. But I think there were discussions in some thread regarding TLS 1.2 or if it was TLS 1.3 which currently wasnt supported and you to contact your sales engineer to file a request.

L4 Transporter

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hello,

First, thanks for your answer.

The document only mention SSL2.0, 3.0 and TLS 1.0. No infos about TLS 1.1 or TLS 1.2...

In my case, we don't have any problem with the certificate itself because the SSL interception is not doing it's job...

I will upgrade 4.1.6 and keep you inform if it's solved or not...

Regards,

Hedi

L4 Transporter

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hello all,

After upgrading to 4.1.6, I can confirm PA is NOT ABLE to decrypt TLS 1.1 or TLS1.2.

I'm waiting an OFFICIAL answer from PA now : When will it be supported ???

Regards,

Hedi

Highlighted

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hi,

as far as i know later Versions of TLS are currently not supported.

This Information was from PanOS 4.0.x

but since i didn't see anything in the Release Notes of 4.1.x it should be still correct.

Regards

Marco

L4 Transporter

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hello,

I totally second your claims. In addition TLS 1.0 is partially finished : it lacks TLS Extensions, which make for example https://www.gmail.com to fail decryption.

Regards

L4 Transporter

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

According to Chrome dev team, newest version has TLS 1.1 disabled because of issues with IIS : Chrome Releases: Stable Channel Update

Thank you Microsoft, you're saving us for once :smileysilly:

L4 Transporter

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hello,

This is answer is receiver from my local SE.

"TLS v1.1 should be supported as of v4.0.x.
I found a note that if diffie hellman is used in the key establishment we can’t decrypt."

"v1.2 seems to be targeted for the next major release (5.x)."


Regards,


Hedi

L4 Transporter

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hello,

I have been in relation for months with product and support managers, it was said many times that 1.1 is not supported and 1.0 is partially (lack of critical extensions).

Strange we don't have same informations :smileygrin:

Anyway, I am always running my own tests and found out that above SSLv2, compatibility is poor.

L3 Networker

Re: SSL Decrypt does NOT work with TLS 1.1 or TLS 1.2

Hello,

Would TLS 1.1 and 1.2 be decrypted by PANOS 5.0 for now?

TLS 1.1 with differ hellman could no be decrypted  on PANOS 5.0 also?

Thanks.

Regards.

Roh

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!