SSL Inbound Decryption with ADFS

Reply
L2 Linker

SSL Inbound Decryption with ADFS

I am seeing issues with inbound decryption and ADFS.  Through investigation, I found that the EC Curve 25519 is not supported, but is the default for Windows 10 and Server 2016.  Per tech support, this will be available in the latter half of 2019 as a supported encryption standard.

 

After moving off of the prevously mentioned curve, I am seeing the following on Windows 10 only. Works as expected on Windows 7:

 

I verified that the new SSL encryption is supported by PA.

 

Microsoft IE - I get an HTTP 400 Bad Request error.  

 

Microsoft IE (In-Private) - Works as expected

 

Chrome / Firefox - Works as expected.

 

I have opened a case with Palo Alto and will update with results.

Highlighted
L2 Linker

Re: SSL Inbound Decryption with ADFS

Installed a preview version of Windows 10 1809 and found that the issue went away.  I am leaning towards a Windows issue in Windows 10 1803.  I will update again after further testing.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!