TLS 1.3 is Coming - How to deal with it????

Reply
L0 Member

Re: TLS 1.3 is Coming - How to deal with it????

We had the same issue.  The response we got from TAC was 1.3 won't be supported until at least 9.1.

 

However, Chrome Beta updated today to Version 70.0.3538.54 (Official Build) beta (64-bit).  Now the sites where we were experiencing the ERR_TL13_DOWNGRADE_DETECTED error are working correctly.  Has anyone else had the same results?

 

I'm not sure what changed from the Chrome side.  There was no update here https://www.chromium.org/Home/tls13

 

L6 Presenter

Re: TLS 1.3 is Coming - How to deal with it????

@Spachtholz wrote:

We had the same issue.  The response we got from TAC was 1.3 won't be supported until at least 9.1.

 

However, Chrome Beta updated today to Version 70.0.3538.54 (Official Build) beta (64-bit).  Now the sites where we were experiencing the ERR_TL13_DOWNGRADE_DETECTED error are working correctly.  Has anyone else had the same results?

 

I'm not sure what changed from the Chrome side.  There was no update here https://www.chromium.org/Home/tls13

 


 

Yes to both.  I heard that there might be some support in 9.0, but really nothing really until 9.1.

 

Also we've been trying to replicate on the same machine / user that reported the problem but we haven't had any issue with any sites.  So I'm not really sure what changed.

L2 Linker

Re: TLS 1.3 is Coming - How to deal with it????

We've got the same issue. Chrome has updated to Version 70.0.3538.67 (Official Build) (64-bit) and we are seeing the error ERR_TLS13_DOWNGRADE_DETECTED

 

We are trying to access pluralsight and schemeserve

L1 Bithead

Re: TLS 1.3 is Coming - How to deal with it????

I have the same issue with SSL Decrypt on PA-3020 PAN OS 8.1.3

 

While searching on this issue I found the following:

 

https://www.chromium.org/Home/tls13?tmpl=%2Fsystem%2Fapp%2Ftemplates%2Fprint%2F&showPrintDialog=1

 

Exerpt:

 

"The only Google service with TLS 1.3 enabled at this time is Gmail, thus Chrome 70 should successfully negotiate TLS 1.3 when connecting to Gmail. However, there is a possibility that bugs in software (such as anti-virus software), or hardware middleboxes, that are between Chrome 70 and a TLS 1.3-enabled service like Gmail will cause problems. We have worked hard to tweak TLS 1.3 in ways that workaround the middleware bugs that we're aware of, but there might be things that we don't know about. Thus, if you see the following situation, you might have some buggy software or hardware that we're not aware of and we would be very interested in the details: 1. Chrome 69 works without issues. 2. Chrome 70 works for most sites except Gmail. 3. Gmail fails to load with ERR_SSL_VERSION_INTERFERENCE or ERR_TLS13_DOWNGRADE_DETECTED."

 

This page also refered to an admin forum thread here:

https://productforums.google.com/forum/#!topic/chrome-admins/jRFqwLUh6YA;context-place=forum/chrome-...

 

 

L2 Linker

Re: TLS 1.3 is Coming - How to deal with it????

Palo Alto decryption appears not to currently support TLS 1.3

If chrome is accessing sites using TLS 1.3 and our Firewalls are trying to decrypt it, we will see this error.

L7 Applicator

Re: TLS 1.3 is Coming - How to deal with it????

Hello All,

The link to the google groups article fixes the issue as it tells Chrome to disable the 1.3 variant.

 

Just paste the following into the chrome browser address field and it should bring it up, then change the setting to 'Disabled'. You will have to restart your browser.

 

chrome://flags/#tls13-variant

 

Cheers!

L1 Bithead

Re: TLS 1.3 is Coming - How to deal with it????

Desabling the 1.3 variant works on my PC, but i'm not sure how I would go about deploying this workaround.  

 

I don't have the option to disable 1.3 variant in my Chrome GPO, at least by that name.

 

Any ideas in that regard?

L1 Bithead

Re: TLS 1.3 is Coming - How to deal with it????

Update on this issue:

 

"We are aware of two vendors whose products have this bug: Cisco and Palo Alto Networks, although there may be more. We reported the issue to Cisco in December 2017. They released the fix this past August and have published an advisory. Palo Alto Networks recently discovered the issue on their devices and are planning to release PAN-OS 8.1.4, PAN-OS 8.0.14, and PAN-OS 7.1.21 to fix this, tentatively by Nov 30th."

 

Full link: 

 

https://www.ietf.org/mail-archive/web/tls/current/msg27066.html

 

L2 Linker

Re: TLS 1.3 is Coming - How to deal with it????

I updated our firmware last night to 8.1.4 and the issue has gone away

Highlighted
L4 Transporter

Re: TLS 1.3 is Coming - How to deal with it????

PAN-OS 8.0.14 and 8.1.4 will support TLS 1.3.

 

 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!