credential tab missing in user id agent 8.0.5-7

Reply
Highlighted
L2 Linker

credential tab missing in user id agent 8.0.5-7

I'm unable to find credintial tab in user id agent. I have downloaded these files UaInstall-8.0.5-7 & UaCredInstall64-8.0.5-7 and installed, both service are also running.

Any one faced this issue? or please let me know how to troubleshoot this issue.

 

Teachnical details

Installed on windows server 2012 r2

DC type is Readonly

 

1.png2.png3.png4.png5.pngService account is preveliged with same permissions which provided for user id agent

Attached the screenshots for your reference.

Community Manager

Re: credential tab missing in user id agent 8.0.5-7

have you tried re-executing the UaCredInstaller and have you tried restarting the userID process afterward ?


Help the community: Like helpful comments and mark solutions
Reaper out
L2 Linker

Re: credential tab missing in user id agent 8.0.5-7

Thanks for your response.

I have restarted both the services under services.msc window, it didn't help. So while credential profgram was running I reinstalled the user id agent, but the result is same.

Do "re execute" mean resinallting the user credentials setup file or execute the of credential application?

I remember user credentials as service so I never run any application for user credential.

 

I am in IST time zone, so if any setup changes I need to do please tell me I will do and update this disuccsion.

 

 

-ram 

Community Manager

Re: credential tab missing in user id agent 8.0.5-7

try re-installing the uacredinstaller (instead of the uidagent)


Help the community: Like helpful comments and mark solutions
Reaper out
L3 Networker

Re: credential tab missing in user id agent 8.0.5-7

I backreved to 8.0.4-5 due to issues with 8.0.5-7 including the one you mention.   There is also another issue which appears to affect a machine based on the XML parser installed, I think.  On one machine I have this setup

 

UserIDAgentConfig.xml

 

<include-exclude-settings>

<net-entry name="Misc4" include="0" address="172.16.4.0/24"/>

</include-exclude-settings>

 

Whereas on the other I have this

 

<include-exclude-settings>

<net-entry name="Misc4" include="0" address="172.16.4.0/24"/>

<include-exclude-settings/>

 

The difference is in where the / is located in the closure.   Copying the settings from one machine to another causes the service to crash with the following errors in UaDebug.log.  My real list has around 30  lines.  I ended up copying the UserIDAgentConfig.xml from one machine to the other and then manually changing where the closing / is located, which worked.  

 

12/22/17 12:18:15:399[Error 2378]: getaddrinfo error: The specified class was not found. !!!!
12/22/17 12:18:15:399[Error 726]: Failed to setup listening sockets
12/22/17 12:18:15:399[Error 753]: Start service failed due to start device link failure!
12/22/17 12:18:15:399[Error 2165]: Start error -1!!
12/22/17 12:18:15:399[Error 764]: Device listening thread stops timeout!
12/22/17 12:18:15:399[ Info 2010]: Service stopped.

 

I spent a lot of time figuring this one out.   Hopefully this helps someone else.

L2 Linker

Re: credential tab missing in user id agent 8.0.5-7

Sorry for the late response, was on leave.

 

It is now working with 8.0.4-5.

Explained what changes i did below

Reaper,

             I reinstalled the user id credential file didn't help.

 

 

Edwind,

Downgraded the user id agent to 8.0.4-5 used with 8.0.5 user id credential agent didn't work.

So installed 8.0.4-5 user id credential along with 8.0.4-5 user id and run the user id with admin permission, credential tab was available.

              in my config.xml of 8.0.4-5 its correct.

 

 

===================================================

<?xml version="1.0" encoding="UTF-8"?>
<user-id-agent-config>
<general-settings>
<authentication username="paruser@TESTAD.COM" dnsdomain="TESTAD.COM" netbiosdomain="testad" password=""/>
<server-monitor security-log-enabled="1" security-log-interval="1" session-enabled="0" session-interval="10" edir-interval="30"/>
<probing wmi-enabled="1" netbios-enabled="1" interval="20" init-retry-delay="3"/>
<timeout enabled="1" entry-timeout="45"/>
<listening-port>5007</listening-port>
<xml-api enabled="0" xml-api-port="5006"/>
<syslog-listening enabled="0" syslog-port="514"/>
<ip-cache enabled="1"/>
<edirectory base-dn="" bind-dn="" search-filter="(objectClass=Person)" domain-prefix="" login-name-attribute="uniqueID" login-address-attribute="networkAddress" login-time-attribute="loginTime" use-ssl="1" verify-certificate="0"/>
<credentials_path enabled="0" path=""/>
<credentials_rodc enabled="0" interval="" auto-discover-replication-policy="1" cacheable-dn=""/>
</general-settings>
<acl-settings>
</acl-settings>
<syslog-profiles>
</syslog-profiles>
<server-settings>
<server-entry name="data.testad.com" type="active-directory" address="192.168.29.187" port="" syslog-profile="" default-domain="">
</server-entry>
</server-settings>
<include-exclude-settings>
</include-exclude-settings>
<custom-securitylog-formats>
</custom-securitylog-formats>
<vmmonitor-settings>
</vmmonitor-settings>
</user-id-agent-config>

===================================================

Thanks for the support

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!