"Install media mount failed" when trying to create bootstrap USB

Reply
L1 Bithead

Re: "Install media mount failed" when trying to create bootstrap USB

I too am using approved Kingston SE 16GB drives, but get failures 99% of the time like this:

admin@PA-220> request system bootstrap-usb prepare from bootstrapcontainer_012801067544_20180928.tar.gz
This will format plugged-in USB and prepare it for bootstrap. This operation may take up to 15 minutes. All the data on USB will be lost. Are you sure you want to continue? (y or n) 

Server error : Install media mount failed, probably bad media(1)

I've created a workaround that seems to ... work.

 

Put your USB stick in a linux box and find the device name (/dev/sdb in this case)

[root@pan-boostrapper ~]# fdisk -l | grep Disk | grep  dev | grep -v mapper
Disk /dev/sda: 21.5 GB, 21474836480 bytes, 41943040 sectors
Disk /dev/sdb: 15.5 GB, 15500574720 bytes, 30274560 sectors

(re)create partitions:

NOTE: Use your own dev location and size from the fdisk command above

[root@pan-boostrapper ~]# parted /dev/sdb
(parted) mklabel msdos
Warning: The existing disk label on /dev/sdb will be destroyed and all data on this disk will be lost. Do you want to continue?
Yes/No? yes
(parted) mkpart pri ext3 1 15.5GB
(parted) quit
Information: You may need to update /etc/fstab.

 Format the new partition:

[root@pan-boostrapper ~]# mkfs.ext3 /dev/sdb1
mke2fs 1.42.9 (28-Dec-2013)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
946560 inodes, 3784188 blocks
189209 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=3875536896
116 block groups
32768 blocks per group, 32768 fragments per group
8160 inodes per group
Superblock backups stored on blocks:
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208

Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information:

done

Mount it

[root@pan-boostrapper ~]# mount /dev/sdb1 /mnt

Make directories and put the init-cfg.txt and bootstrap.xml in them

[root@pan-boostrapper ~]# ls -l pan-bootstrap/*
pan-bootstrap/config:
total 16
-rwx------. 1 root root 9016 Sep 30 11:41 bootstrap.xml
-rwx------. 1 root root  243 Sep 30 11:41 init-cfg.txt

pan-bootstrap/license:
total 0

pan-bootstrap/log:
total 0

And copy stuff in there

[root@pan-boostrapper ~]# cp -r pan-bootstrap/* /mnt/

umount and off you go

[root@pan-boostrapper ~]# umount /mnt
L1 Bithead

Re: "Install media mount failed" when trying to create bootstrap USB

Also... this was on 8.0.7.   Fixed PAN-79317 at 8.0.10
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!