Software Upgrade Problems on PA-200 Devices

Printer Friendly Page

Issue

Attempts to upgrade PA-200 devices to a maintenance release on a later major software version fail. Specifically, after successfully downloading the base software image (for example, PAN-OS 6.0.0), the download of the maintenance release fails with errors similar to the following:

  • The required '6.0' base image must be loaded before this image can be loaded. You do not have to install or run the base image, only download it. Once the base is loaded, re-download your target image.
  • Failed to load into software manager. Please retry.
  • Post processing failed. Please retry.

sw-download.JPG.jpg

As the screenshot shows, the 6.0.0 image is present on the system. However, after closing the dialog box and refreshing the software page, the 6.0.0 image disappears.

 

Cause

Base images can be prematurely purged from the system due to limited storage capacity on PA-200 series devices.

 

Resolution

To upgrade PA-200 devices to maintenance releases on later major versions of PAN-OS:

  1. Delete any unused PAN-OS images present on the firewall to free some space on the device.
  2. Download base software image (for example, 6.0.0).
  3. Install base software image without rebooting.
  4. Download desired maintenance release software image (for example, 6.0.2).
  5. Install maintenance release and reboot.

 

owner: garrison

Tags (6)
Comments

 I ran into this upgrading a PA-200 from 5.0.6 to 6.1.8. I first upgraded from 5.0.6 to 6.0.0 and rebooted. I then downloaded the 6.1.0 but did not install. Tried downloading 6.1.8 to install but got this error. Glad I found this article. I performed the steps as indicated and successfully upgraded to 6.1.8

I found this article but it is not working for me when I try to upgrade the PA-200 from 7.0.8 to 7.1.2.

The strangest thing is that I can upgrade from 7.0.8 to 7.1.0 but when I try to upgrade from there to 7.1.2. it still is giving me this message saying that the base image of 7.1.0 is not loaded even though on the dashboard it is clearly to see that it is running version 7.1.0.

When I try to upload the 7.1.0 image it is telling me that the image is already uploaded, but it still fails to install 7.1.2

@StefanvH : have you tried deleting all other PAN-OS images from the system (besides 7.0.0,  7.0.8 and 7.1.0)?

Hi

Yes, I have deleted all images but one (the current running 7.0.8 after revert from 7.1.0) and I have also tried uploading first 7.0.1 (as 7.0.0 does not exist) then 7.1.0 and then uploading 7.1.2 and then tried installing 7.1.2 but it still gives me the same message.

 

can you try going over these steps: How and When to Clear Disk Space on the Palo Alto Networks Device

 

As a last resort you could try performing a factory reset How to perform a Factory Reset a Palo Alto Networks Device

Tried all that but it doesn't help.

Could it be because of the license have been expired on the device that I am no longer able to upgrade it to version 7.1 ?

The license have been expired for a long time, the device is only used for testing purposes and I was always able to upgrade from version 5 up to the current running version 7.0.9.

 

EDIT: Just came to the conclusion that I haven't tried upgrading from 7.0.9. 
So I tried installing the base image 7.1.0 first without rebooting and that went well without any errors and after that I uploaded 7.1.4h2 and start to install it.

Now it seems to load the image succesfully into the software manager and the upgrade is running.
So I guess something has been fixed in 7.0.9

I have had the same problems from several releases. My other "problem" is that my PA200 boxes has a <512kbps satelitte link, and redownloading images is a pain.

 

My workaround is to always bring the PA200 to latest minor release, then deleting all other releases before upgrading to next major, and then to my choosen minor.

I had the same issue on PA3050. upgrade from 7.0.6 to 7.1.6.

After downloading 7.1.0 image tried to download 7.1.6 the action failed with the following message:

 

  • The required '7.1' base image must be loaded before this image can be loaded. You do not have to install or run the base image, only download it. Once the base is loaded, re-download your target image.
  • Failed to load into software manager. Please retry.

 

Tried to upload images manually - got the same errors.

Problem resolved after rebooted the device and downloaded all images again.