Migration Tool 3.1 erroring on Generating API requests

Reply
Highlighted
L0 Member

Migration Tool 3.1 erroring on Generating API requests

I am getting an error when generating API requests:

 

PHP Warning: get_class() expects parameter 1 to be object, boolean given in /var/www/html/libs/xmlapi.php on line 658, referer: https://
PHP Fatal error: Uncaught exception 'Exception' with message 'Wrong type of input parameters, expected SimpleXMLElement key:value:' in /var/www/html/libs/xmlapi.php:677\nStack trace:\n#0 /var/www/html/bin/OUTPUT-API.php(2632): SimpleXMLElement_append(Object(SimpleXMLElement), false)\n#1 {main}\n thrown in /var/www/html/libs/xmlapi.php on line 677, referer: https://

 

I have gone through all my shared objects to eliminate any duplicates, but am still receiving the error.

 

Is there any way to see which record is causing the error?

L7 Applicator

Re: Migration Tool 3.1 erroring on Generating API requests

Hi,

 

Is your Base Config a Panorama? If yes, Have you checked the Interfaces? 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!