Azure IP prefixes

Reply
L0 Member

Azure IP prefixes

Hi folks

 

I'm trying to get Minemeld to output a list of Azure IP prefixes related to specific services, and getting very mixed results.  My config so far:

 

Miner - built in 'azure.cloudIPs'

Processor - built in 'stdlib.aggregatorIPv4Generic'

Output - a customised version of 'stdlib.feedHCGreen'

 

For the Ouput, I customised the built in prototype infilter to add the line "azure_name == 'AzureBackup.WestEurope'", as determined by looking at some of the logs.

 

The configuration is accepted and it seems to run ok, but when you look at the ouput in detail some of the prefixes are missing.  For example, I should see 6 x prefixes for this service, but the output only lists 4.  I can find the missing prefixes in the logs.  The miner identifies it correctly, the aggreagtor identifies it correctly, but the 'emit_update' entry has changed the 'azure_name' to 'AzureCloud' and so the ouputer drops it as it doesn't match the infilter.  See log details below.

 

What am I getting wrong?

 

Thanks

 

AggAccept.PNGAggEmit.PNG

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!