Cannot retrieve indicators from FS-ISAC feed

L1 Bithead

Cannot retrieve indicators from FS-ISAC feed

I recently created a feed over at FS-ISAC for my organization, and I'm able to connect successfully from within MineMeld, however I am not receiving any indicators. My initial_interval is set to 30d and when I test using 'taxii-poll' from the shell I'm able to retrieve indicators that way, so I know the feed I'm publishing is working, but MineMeld shows 0 indicators. Any ideas where to look next? I've checked the engine logs and there are no errors, and the miner has zero logs.
L1 Bithead

Re: Cannot retrieve indicators from FS-ISAC feed

So, here's the configuration of my TaxiiClient prototype:

 

age_out:
    default: last_seen+30d
    sudden_death: false
attributes:
    confidence: 100
    share_level: green
client_cert_required: true
collection: <user.feed>
discovery_service: https://analysis.fsisac.com/taxii-discovery-service
initial_interval: 30d
source_name: fsisac.<user.feed>

 

I've tried this with both last_seen+30d and null, as well as varying initial_interval and setting the feed in FS-ISAC to only IP Watchlist and Indicators, just in case it was an issue parsing certain items, but it still retrieves 0 indicators.

L1 Bithead

Re: Cannot retrieve indicators from FS-ISAC feed

After turning on verbose logging, I was able to see what was happening when MineMeld retrieved my feed from FS-ISAC. Ultimately, I solved the problem by publishing a feed containing 'observables' and not just indicators.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!