Configured, Enabled Nodes not showing up under Minemeld > Nodes.

Reply
L3 Networker

Configured, Enabled Nodes not showing up under Minemeld > Nodes.

After reboot, none of the configured nodes (all enabled) are showing up under "Nodes". Tried restarting services and VM. Further configuration commits without any errors, but still no nodes show up.

 

Minemeld logs attached. (/opt/minemeld/logs/*)

 

Any ideas where to start troubleshooting?

 

-Nasir

Tags (1)
L7 Applicator

Re: Configured, Enabled Nodes not showing up under Minemeld > Nodes.

Hi Nasir,

you should install additional packages:

 

librabbitmq1
libsnappy1
libleveldb1

You can see the error in minemeld-engine.log, the engine is trying to load a missing shared library:

 

Traceback (most recent call last):
  File "/usr/lib/python2.7/multiprocessing/process.py", line 258, in _bootstrap
    self.run()
  File "/usr/lib/python2.7/multiprocessing/process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/minemeld/run/launcher.py", line 45, in _run_chassis
    c.configure(fts)
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/minemeld/chassis.py", line 88, in configure
    config=ftconfig.get('config', {})
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/minemeld/ft/__init__.py", line 22, in factory
    return _dynamic_load(classname)(
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/minemeld/ft/__init__.py", line 14, in _dynamic_load
    t = __import__(modname, globals(), locals(), [classname])
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/minemeld/ft/http.py", line 20, in <module>
    from . import basepoller
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/minemeld/ft/basepoller.py", line 23, in <module>
    from . import table
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/minemeld/ft/table.py", line 73, in <module>
    import plyvel
  File "/opt/minemeld/engine/0.9.9.1/local/lib/python2.7/site-packages/plyvel/__init__.py", line 6, in <module>
    from ._plyvel import (  # noqa
ImportError: libleveldb.so.1: cannot open shared object file: No such file or directory
L3 Networker

Re: Configured, Enabled Nodes not showing up under Minemeld > Nodes.

There's about 4000+ occurrences of this error in the Engine logs:

"ImportError: libleveldb.so.1: cannot open shared object file: No such file or directory" where is that file supposed to be and how can I get it? Perhaps some library didn't install properly?

 

Should I just do an apt-get install libleveldb-dev?

http://packages.ubuntu.com/search?keywords=libleveldb-dev

 

-Nasir

L3 Networker

Re: Configured, Enabled Nodes not showing up under Minemeld > Nodes.

Beat me to it by 3 minutes! :)

 

Had to reboot my workstation...will try in a few and let you know.

 

Thanks!

Nasir

L7 Applicator

Re: Configured, Enabled Nodes not showing up under Minemeld > Nodes.

You don't need the -dev packages as all the code is already compiled inside the MineMeld packages. Just the "production" packages I have listed in the previous message.

L3 Networker

Re: Configured, Enabled Nodes not showing up under Minemeld > Nodes.

That was it. I will add these to the posted solution under the Proxy discussion for future reference. Thanks!

Tags (1)
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!