Error at task npm install on RHEL 7.6

Reply
L1 Bithead

Error at task npm install on RHEL 7.6

Hi, we are trying to install Minemeld using ansible and we are having the following error

 


TASK [minemeld : npm install] ***************************************************************************************************************************************************************************************************************
fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": ["npm", "install"], "delta": "0:01:00.976428", "end": "2019-02-27 15:46:25.871711", "msg": "non-zero return code", "rc": -9, "start": "2019-02-27 15:45:24.895283", "stderr": "npm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css\nnpm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5\nnpm WARN deprecated nsp@2.4.0: The Node Security Platform service is shutting down 9/30 - https://blog.npmjs.org/post/175511531085/the-node-security-platform-service-is-shutting\nnpm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.\nnpm WARN deprecated bower@1.8.4: This Bower version has SECURITY BUG THAT ALLOWS TO WRITE TO ARBITRARY FILE ON YOUR COMPUTER when you install malicious package. Please upgrade Bower to at least version 1.8.8 if you don't want to get hacked. More info: https://snyk.io/blog/severe-security-vulnerability-in-bowers-zip-archive-extraction/\nnpm WARN deprecated typings@0.8.1: Typings is deprecated in favor of NPM @types -- see README for more information\nnpm WARN deprecated joi@6.10.1: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated wreck@6.3.0: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated topo@1.1.0: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated node-uuid@1.4.7: Use uuid module instead\nnpm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130\nnpm WARN deprecated minimatch@3.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated is-my-json-valid@2.13.1: catastrophic backtracking in regexes could potentially lead to REDOS attack, upgrade to 2.17.2 as soon as possible\nnpm WARN deprecated express@2.5.11: express 2.x series is deprecated\nnpm WARN deprecated connect@1.9.2: connect 1.x series is deprecated\nnpm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later\nnpm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js\nnpm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js\nnpm WARN deprecated gulp-footer@1.1.2: Security vulnerability surrounding event-stream, do *NOT* use.\nnpm WARN deprecated gulp-header@1.8.12: Removed event-stream from gulp-header\nnpm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.\nnpm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.\nnpm WARN deprecated node-uuid@1.4.8: Use uuid module instead\nnpm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated npmconf@1.1.5: this package has been reintegrated into npm and is now out of date with respect to npm\nnpm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "stderr_lines": ["npm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css", "npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5", "npm WARN deprecated nsp@2.4.0: The Node Security Platform service is shutting down 9/30 - https://blog.npmjs.org/post/175511531085/the-node-security-platform-service-is-shutting", "npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.", "npm WARN deprecated bower@1.8.4: This Bower version has SECURITY BUG THAT ALLOWS TO WRITE TO ARBITRARY FILE ON YOUR COMPUTER when you install malicious package. Please upgrade Bower to at least version 1.8.8 if you don't want to get hacked. More info: https://snyk.io/blog/severe-security-vulnerability-in-bowers-zip-archive-extraction/", "npm WARN deprecated typings@0.8.1: Typings is deprecated in favor of NPM @types -- see README for more information", "npm WARN deprecated joi@6.10.1: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated wreck@6.3.0: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated topo@1.1.0: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated node-uuid@1.4.7: Use uuid module instead", "npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130", "npm WARN deprecated minimatch@3.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated is-my-json-valid@2.13.1: catastrophic backtracking in regexes could potentially lead to REDOS attack, upgrade to 2.17.2 as soon as possible", "npm WARN deprecated express@2.5.11: express 2.x series is deprecated", "npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated", "npm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later", "npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "npm WARN deprecated gulp-footer@1.1.2: Security vulnerability surrounding event-stream, do *NOT* use.", "npm WARN deprecated gulp-header@1.8.12: Removed event-stream from gulp-header", "npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.", "npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.", "npm WARN deprecated node-uuid@1.4.8: Use uuid module instead", "npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated npmconf@1.1.5: this package has been reintegrated into npm and is now out of date with respect to npm", "npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js"], "stdout": "", "stdout_lines": []}

 

We are using the master repository: ansible-playbook -K -e "minemeld_version=master" -i 127.0.0.1, local.yml

 

Did someone have the same issue using RHEL? Thanks!

L1 Bithead

Re: Error at task npm install on RHEL 7.6

I tried the installation of minemeld using Ubuntu 16.04 with Ansible too. Im getting the same error, any clues?

 

TASK [minemeld : npm install] ***************************************************************************************************************************************************************************************************************
fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": ["npm", "install"], "delta": "0:04:38.759471", "end": "2019-03-04 16:00:00.440144", "msg": "non-zero return code", "rc": 1, "start": "2019-03-04 15:55:21.680673", "stderr": "npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5\nnpm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.\nnpm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css\nnpm WARN deprecated nsp@2.4.0: The Node Security Platform service is shutting down 9/30 - https://blog.npmjs.org/post/175511531085/the-node-security-platform-service-is-shutting\nnpm WARN deprecated bower@1.8.8: We don't recommend using Bower for new projects. Please consider Yarn and Webpack or Parcel. You can read how to migrate legacy project here: https://bower.io/blog/2017/how-to-migrate-away-from-bower/\nnpm WARN deprecated typings@0.8.1: Typings is deprecated in favor of NPM @types -- see README for more information\nnpm WARN deprecated wreck@6.3.0: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated joi@6.10.1: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated topo@1.1.0: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130\nnpm WARN deprecated node-uuid@1.4.7: Use uuid module instead\nnpm WARN deprecated minimatch@3.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated is-my-json-valid@2.13.1: catastrophic backtracking in regexes could potentially lead to REDOS attack, upgrade to 2.17.2 as soon as possible\nnpm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.\nnpm WARN deprecated express@2.5.11: express 2.x series is deprecated\nnpm WARN deprecated connect@1.9.2: connect 1.x series is deprecated\nnpm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later\nnpm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js\nnpm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js\nnpm WARN deprecated gulp-header@1.8.12: Removed event-stream from gulp-header\nnpm WARN deprecated gulp-footer@1.1.2: Security vulnerability surrounding event-stream, do *NOT* use.\nnpm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.\nnpm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.\nnpm WARN deprecated node-uuid@1.4.8: Use uuid module instead\nnpm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated npmconf@1.1.5: this package has been reintegrated into npm and is now out of date with respect to npm\nnpm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js\nnpm WARN prefer global node-gyp@3.8.0 should be installed with -g", "stderr_lines": ["npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5", "npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.", "npm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css", "npm WARN deprecated nsp@2.4.0: The Node Security Platform service is shutting down 9/30 - https://blog.npmjs.org/post/175511531085/the-node-security-platform-service-is-shutting", "npm WARN deprecated bower@1.8.8: We don't recommend using Bower for new projects. Please consider Yarn and Webpack or Parcel. You can read how to migrate legacy project here: https://bower.io/blog/2017/how-to-migrate-away-from-bower/", "npm WARN deprecated typings@0.8.1: Typings is deprecated in favor of NPM @types -- see README for more information", "npm WARN deprecated wreck@6.3.0: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated joi@6.10.1: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated topo@1.1.0: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130", "npm WARN deprecated node-uuid@1.4.7: Use uuid module instead", "npm WARN deprecated minimatch@3.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated is-my-json-valid@2.13.1: catastrophic backtracking in regexes could potentially lead to REDOS attack, upgrade to 2.17.2 as soon as possible", "npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.", "npm WARN deprecated express@2.5.11: express 2.x series is deprecated", "npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated", "npm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later", "npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "npm WARN deprecated gulp-header@1.8.12: Removed event-stream from gulp-header", "npm WARN deprecated gulp-footer@1.1.2: Security vulnerability surrounding event-stream, do *NOT* use.", "npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.", "npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.", "npm WARN deprecated node-uuid@1.4.8: Use uuid module instead", "npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated npmconf@1.1.5: this package has been reintegrated into npm and is now out of date with respect to npm", "npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "npm WARN prefer global node-gyp@3.8.0 should be installed with -g"], "stdout": "\n> node-sass@3.13.1 install /opt/minemeld/www/webui/node_modules/node-sass\n> node scripts/install.js", "stdout_lines": ["", "> node-sass@3.13.1 install /opt/minemeld/www/webui/node_modules/node-sass", "> node scripts/install.js"]}

L1 Bithead

Re: Error at task npm install on RHEL 7.6

Hi,

 

finally I found the problem, I was running out of RAM. So I just increased the RAM and it's working now.

I wasn't able to find the npm debug log but once I found it the error message was clear.

 

 

L7 Applicator

Re: Error at task npm install on RHEL 7.6

Hi @Rodrigobe,

thanks for share the solution

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!