Error at task npm install on RHEL

Reply
Highlighted
L1 Bithead

Error at task npm install on RHEL

Hi all,

I'm installing minemeld-ansible on Redhat 7.
When i run this command:

sudo ansible-playbook -K -i 127.0.0.1, local.yml

I got this error:

TASK [minemeld : npm install] *********************************************************************************************************************************************************************************
fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": ["npm", "install"], "delta": "0:01:00.183714", "end": "2019-10-11 13:18:05.661103", "msg": "non-zero return code", "rc": 228, "start": "2019-10-11 13:17:05.477389", "stderr": "npm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css\nnpm WARN deprecated nsp@2.4.0: The Node Security Platform service is shutting down 9/30 - https://blog.npmjs.org/post/175511531085/the-node-security-platform-service-is-shutting\nnpm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5\nnpm WARN deprecated typings@0.8.1: Typings is deprecated in favor of NPM @types -- see README for more information\nnpm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.\nnpm WARN deprecated bower@1.8.8: We don't recommend using Bower for new projects. Please consider Yarn and Webpack or Parcel. You can read how to migrate legacy project here: https://bower.io/blog/2017/how-to-migrate-away-from-bower/\nnpm WARN deprecated joi@6.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).\nnpm WARN deprecated wreck@6.3.0: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).\nnpm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).\nnpm WARN deprecated boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).\nnpm WARN deprecated topo@1.1.0: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).\nnpm WARN deprecated node-uuid@1.4.7: Use uuid module instead\nnpm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130\nnpm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.\nnpm WARN deprecated minimatch@3.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated is-my-json-valid@2.13.1: catastrophic backtracking in regexes could potentially lead to REDOS attack, upgrade to 2.17.2 as soon as possible\nnpm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.\nnpm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).\nnpm WARN deprecated express@2.5.11: express 2.x series is deprecated\nnpm WARN deprecated connect@1.9.2: connect 1.x series is deprecated\nnpm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later\nnpm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated json3@3.3.2: Please use the native JSON object instead of JSON 3\nnpm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js\nnpm WARN deprecated natives@1.1.6: This module relies on Node.js's internals and will break at some point. Do not use it, and update to graceful-fs@4.x.\nnpm WARN deprecated gulp-footer@1.1.2: Security vulnerability surrounding event-stream, do *NOT* use.\nnpm WARN deprecated gulp-header@1.8.12: Removed event-stream from gulp-header\nnpm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.\nnpm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.\nnpm WARN deprecated node-uuid@1.4.8: Use uuid module instead\nnpm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue\nnpm WARN deprecated npmconf@1.1.5: this package has been reintegrated into npm and is now out of date with respect to npm\nnpm WARN deprecated popsicle-proxy-agent@1.0.0: Use `agent` option with `popsicle` directly\nnpm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js\nnpm ERR! tar.unpack untar error /root/.npm/bower/1.8.8/package.tgz\nnpm ERR! tar.unpack untar error /root/.npm/rxjs/5.5.12/package.tgz\nnpm ERR! tar.unpack untar error /root/.npm/bower/1.8.8/package.tgz\nnpm ERR! tar.unpack untar error /root/.npm/rxjs/5.5.12/package.tgz\nnpm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):\nnpm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {\"os\":\"darwin\",\"arch\":\"any\"} (current: {\"os\":\"linux\",\"arch\":\"x64\"})\nnpm WARN minemeldWebui@0.9.64 No repository field.\nnpm WARN minemeldWebui@0.9.64 No license field.\nnpm ERR! Linux 3.10.0-327.36.3.el7.x86_64\nnpm ERR! argv \"/opt/minemeld/www/venv/bin/node\" \"/opt/minemeld/www/venv/bin/npm\" \"install\"\nnpm ERR! node v6.14.4\nnpm ERR! npm  v3.10.10\nnpm ERR! code ENOSPC\nnpm ERR! errno -28\nnpm ERR! syscall write\n\nnpm ERR! nospc ENOSPC: no space left on device, write\nnpm ERR! nospc This is most likely not a problem with npm itself\nnpm ERR! nospc and is related to insufficient space on your system.\n\nnpm ERR! Please include the following file with any support request:\nnpm ERR!     /opt/minemeld/www/webui/npm-debug.log", "stderr_lines": ["npm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css", "npm WARN deprecated nsp@2.4.0: The Node Security Platform service is shutting down 9/30 - https://blog.npmjs.org/post/175511531085/the-node-security-platform-service-is-shutting", "npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5", "npm WARN deprecated typings@0.8.1: Typings is deprecated in favor of NPM @types -- see README for more information", "npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.", "npm WARN deprecated bower@1.8.8: We don't recommend using Bower for new projects. Please consider Yarn and Webpack or Parcel. You can read how to migrate legacy project here: https://bower.io/blog/2017/how-to-migrate-away-from-bower/", "npm WARN deprecated joi@6.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).", "npm WARN deprecated wreck@6.3.0: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).", "npm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).", "npm WARN deprecated boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).", "npm WARN deprecated topo@1.1.0: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).", "npm WARN deprecated node-uuid@1.4.7: Use uuid module instead", "npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130", "npm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.", "npm WARN deprecated minimatch@3.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated is-my-json-valid@2.13.1: catastrophic backtracking in regexes could potentially lead to REDOS attack, upgrade to 2.17.2 as soon as possible", "npm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.", "npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).", "npm WARN deprecated express@2.5.11: express 2.x series is deprecated", "npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated", "npm WARN deprecated formidable@1.0.17: Old versions of Formidable are not compatible with the current Node.js; Upgrade to 1.2.0 or later", "npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated json3@3.3.2: Please use the native JSON object instead of JSON 3", "npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "npm WARN deprecated natives@1.1.6: This module relies on Node.js's internals and will break at some point. Do not use it, and update to graceful-fs@4.x.", "npm WARN deprecated gulp-footer@1.1.2: Security vulnerability surrounding event-stream, do *NOT* use.", "npm WARN deprecated gulp-header@1.8.12: Removed event-stream from gulp-header", "npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.", "npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.", "npm WARN deprecated node-uuid@1.4.8: Use uuid module instead", "npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue", "npm WARN deprecated npmconf@1.1.5: this package has been reintegrated into npm and is now out of date with respect to npm", "npm WARN deprecated popsicle-proxy-agent@1.0.0: Use `agent` option with `popsicle` directly", "npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js", "npm ERR! tar.unpack untar error /root/.npm/bower/1.8.8/package.tgz", "npm ERR! tar.unpack untar error /root/.npm/rxjs/5.5.12/package.tgz", "npm ERR! tar.unpack untar error /root/.npm/bower/1.8.8/package.tgz", "npm ERR! tar.unpack untar error /root/.npm/rxjs/5.5.12/package.tgz", "npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):", "npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {\"os\":\"darwin\",\"arch\":\"any\"} (current: {\"os\":\"linux\",\"arch\":\"x64\"})", "npm WARN minemeldWebui@0.9.64 No repository field.", "npm WARN minemeldWebui@0.9.64 No license field.", "npm ERR! Linux 3.10.0-327.36.3.el7.x86_64", "npm ERR! argv \"/opt/minemeld/www/venv/bin/node\" \"/opt/minemeld/www/venv/bin/npm\" \"install\"", "npm ERR! node v6.14.4", "npm ERR! npm  v3.10.10", "npm ERR! code ENOSPC", "npm ERR! errno -28", "npm ERR! syscall write", "", "npm ERR! nospc ENOSPC: no space left on device, write", "npm ERR! nospc This is most likely not a problem with npm itself", "npm ERR! nospc and is related to insufficient space on your system.", "", "npm ERR! Please include the following file with any support request:", "npm ERR!     /opt/minemeld/www/webui/npm-debug.log"], "stdout": "minemeldWebui@0.9.64 /opt/minemeld/www/webui\n

 

 

Someone could help me ?
thanks

EC
L1 Bithead

Re: Error at task npm install on RHEL

I solved by expanding the disk memory.

EC
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!