Not seeing a customized prototype in GUI

Reply
L1 Bithead

Not seeing a customized prototype in GUI

Hello team!

 

I hope you are doing alright.

Currently, I am trying to add a customized miner prototype and while creating it in the /opt/minemeld/local/prototypes/ folder, I am not able to see in added in the GUI.

 

What could be the problem here?

 

Thanks in advance!

 

Best regards,

Petar

L7 Applicator

Re: Not seeing a customized prototype in GUI

Did you restart the API process after adding the file? System > API > RESTART

The API process caches in memory the prototypes on disk, to refresh the cache you just restart the only API process.

L1 Bithead

Re: Not seeing a customized prototype in GUI

Sure, I did.

I also tried restarting the whole server - without any luck.

 

I also tried to create a new prototype in the GUI with minemeld.ft.taxii.TaxiiClient class and it got the message that it is successfully added, but not seem to find it. This created another file in the .../local/... directory but still it is not visible in the GUI.

 

Any other suggestions?

 

Best regards,

Petar

L7 Applicator

Re: Not seeing a customized prototype in GUI

Could you share the new prototype if possible?

L1 Bithead

Re: Not seeing a customized prototype in GUI

Here it is, without the correct URL and credentials:

 

author: minemeld-web
description: Local prototype library managed via MineMeld WebUI
prototypes:
    PL_ThreatMonitoring:
        class: minemeld.ft.taxii.TaxiiClient
        config:
                age_out:
                        default: last_seen+7d
                        sudden_death: false
                attributes:
                        confidence: 100
                        share_level: green
                collection: system.Default
                discovery_service: https://url.com/test
                password: ###pass###
                source_name: pl.system.default
                username: ###user###
        description: Test
        development_status: EXPERIMENTAL
        indicator_types:
        - URL
        - domain
        - IPv4
        - IPv6
        node_type: miner
        tags:
        - ShareLevelGreen
~
~

"phishlabs.yml" 27L, 668C   

 

L1 Bithead

Re: Not seeing a customized prototype in GUI

I'm having the same problem, unab;e tp see locall prototypes in the GUI. I've tried adding one manually by creating a .yml file in /opt/minemeld/local/prototypes and also by creating one using the GUI. But new prototypes do not show up in the GUI interface. I've also tried restarting the API as advised, but no luck.

 

Any thoughts on this?

 

(I'm running on Ubuntu 16.04.05)

 

Regards,

Tony.

L1 Bithead

Re: Not seeing a customized prototype in GUI

Hey @Tony-Arnold,

 

I couldn't find a root cause for this. But after pre-installation of the Ubuntu OS and Minemeld from scratch, this started working.

 

Best regards,

Petar

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!