TAXII feed for SIEM

Reply
L4 Transporter

Re: TAXII feed for SIEM

@lmori I have got required configuration updated in the config file. Please note that the command to reload minemeld api worked fine in cli however there was warning in GUI "Error loading config" and indicators to "0". I restarted the VM and the gui loaded fine with all required nodes with indicator data. Now the error has changed on SIEM. I am not sure if the MineMeld configuration needs further tweaking.

ERROR
Error issuing TAXII request, HTTP response code: 400: Invalid message

 

 

L7 Applicator

Re: TAXII feed for SIEM

Would you be available for a webmeeting? We could speed up the integration tests this way.
Just send me an email at lmori@paloaltonetworks.com

Thanks,
Luigi
L7 Applicator

Re: TAXII feed for SIEM

@Sly_Cooper that error message typically happens when you try to access a TAXII feed that does not exist. Could you post the screenshot of your MM config and the config of McAfee SIEM ?

 

Thanks !

luigi

L4 Transporter

Re: TAXII feed for SIEM

Screenshot_1.pngScreenshot_2.pngClipboard01.jpg

L4 Transporter

Re: TAXII feed for SIEM

McAfee SIEM Config and error

Screenshot_3.png

L7 Applicator

Re: TAXII feed for SIEM

@Sly_Cooper could you post or send me the log /opt/minemeld/log/minemeld-web.log ?

 

Thanks,

luigi

L4 Transporter

Re: TAXII feed for SIEM

@lmori Logs attached.

L7 Applicator

Re: TAXII feed for SIEM

@Sly_Cooper thanks !

I have checked and you should change the config this way (note the URL now set to https://<minemeld>/taxii-poll-service):

 

1473090019878screensave.png

 

Basically you have to specify URL of the TAXII poll service, not the URL of the discovery service.

 

After that indicators can be sucessfully downloaded:

 

Screen Shot 2016-09-05 at 17.42.17.png

L4 Transporter

Re: TAXII feed for SIEM

@lmori Thank you. It worked! I could see the indicators in the watchlist. I will continue to work with minemeld and SIEM.

 

FYI - The Minemeld instance failed automatically with error reading config message. All indicators went to zero. It started back automatically when checked after two days.

L7 Applicator

Re: TAXII feed for SIEM

@Sly_Cooper could you send me the file /opt/minemeld/log/minemeld-engine.log to check the error in reading the config ?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!