Updating MineMeld

Reply
L0 Member

Updating MineMeld

Hi Guys

 

I am running 0.9.48 and want to get to 0.9.50+ to utilise the latest Office365 feeds.  I have checked the old method and I don't have the auto update utility installed 

/usr/sbin/minemeld-auto-update

 If it try this method as suggested

 sudo add-apt-repository -ry ppa:adiscon/v8-stable
$ wget -qO - https://minemeld-updates.panw.io/gpg.key | sudo apt-key add -
$ sudo add-apt-repository "deb http://minemeld-updates.panw.io/ubuntu trusty-minemeld main"
$ sudo apt-get update && sudo apt-get install -y minemeld

 I get the follow errors:

The following packages have unmet dependencies:
 minemeld : Depends: librabbitmq1 but it is not installable
            Depends: libsnappy1 but it is not installable
            Depends: libleveldb1 but it is not installable
            Recommends: rsyslog-mmnormalize (>= 8.14) but it is not going to be installed
            Recommends: rsyslog-minemeld but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

 

Any suggestions?

L7 Applicator

Re: Updating MineMeld

Hi @Ben_Tulloch,

which Linix distribution are you using?

 

If the auto update is not there, I guess you installed via Ansible. Please use this method to update: https://github.com/PaloAltoNetworks/minemeld-ansible/issues/49#issuecomment-436059493

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!