error activating extension

Reply
L1 Bithead

error activating extension

Hi Guys need some help.

 

I copied the taxii class and renamed it then i followed youtubeminer to make and extension out of it. when I install it it shows me install success and shows success in activation. but i don't see the prototype in the list.

 

 

In the logs in see:

 

loader._initialize_entry_point_group ERROR: vinamrataxii.prototypes not loadable: werkzeug not installed

 

I check the mm-jobs-extention file i see werkzeug Requirement already satisfied: Werkzeug==0.14.1 in /opt/minemeld/engine/current/lib/python2.7/site-packages

 

pip also outputs same

 

I am not sure where else i can install Werkzeug to load the extension properly


minemeld-engine.log

2018-05-03T21:17:08 (18834)launcher._run_chassis INFO: power off 2018-05-03T21:17:09 (18816)launcher.main INFO: One of the chassis has stopped, exit 2018-05-03T21:17:11 (19333)launcher.main INFO: Starting mm-run.py version 0.9.44.post1 2018-05-03T21:17:11 (19333)launcher.main INFO: mm-run.py arguments: Namespace(config='/opt/minemeld/local/config', multiprocessing=0, nodes_per_chassis=15.0, verbose=False) 2018-05-03T21:17:11 (19333)loader._initialize_entry_point_group ERROR: vinamrataxii.prototypes not loadable: werkzeug not installed 2018-05-03T21:17:11 (19333)config.resolve_prototypes INFO: Prototypes entrypoint vinamrataxii.prototypes not loadable 2018-05-03T21:17:12 (19333)loader._initialize_entry_point_group ERROR: vinamrataxii.VinamraTaxiiClient not loadable: werkzeug not installed 2018-05-03T21:17:12 (19333)config.resolve_prototypes INFO: Prototypes entrypoint vinamrataxii.prototypes not loadable 2018-05-03T21:17:13 (19333)config._load_config_from_dir INFO: Switching to candidate config 2018-05-03T21:17:13 (19333)config._load_config_from_dir INFO: Changes in config: []
L7 Applicator

Re: error activating extension

Hi @VBhatnagar,

if you want to build a new TAXII Miner as an extension, I would start from here:

https://github.com/PaloAltoNetworks/minemeld-taxii-ng

 

It's a new non-opinionated TAXII Miner we are working on and it is structured as an extension.

L1 Bithead

Re: error activating extension

 Hi lmori,

 

I tried minemeld-taxii-ng but there are lots of issues in that so i used the other taxii miner. I already have the code that I wanted to build for taxii miner.

 

Can you help me figuring out this issue?

 

Thanks

Vinamra

L1 Bithead

Re: error activating extension

Hi Guys,

 

Any help would be really appriciated.

 

Thanks

Vinamra

L1 Bithead

Re: error activating extension

So I removed werkzeug  from requirements.txt and prototype installs without error but i cant see my prototype in the list.

i dont see any error in minemeld-engine.log

L1 Bithead

Re: error activating extension

Guys i am out of options now. 

 

https://github.com/vinamra2004/vinamrataxii

 

is my extention. if any one can help me out why prototype is not listed under prototypes in web UI that would be great.

 

Thanks

Vinamra

L1 Bithead

Re: error activating extension

I tried to force test by adding the prototype in running config and saw error related to prototype yml.

 

So I checked the prototype yml syntax and found issues.

 

After fixing the yml I redeployed the extention. Now I can see the prototype in the Prototype list and can create a node out of it but when I commit/restart the engine. I get following errors:

 

 

Traceback (most recent call last):
  File "/opt/minemeld/engine/core/minemeld/run/launcher.py", line 53, in _run_chassis
    c.configure(fts)
  File "/opt/minemeld/engine/core/minemeld/chassis.py", line 102, in configure
    config=ftconfig.get('config', {})
  File "/opt/minemeld/engine/core/minemeld/ft/__init__.py", line 5, in factory
    node_class = load(MM_NODES_ENTRYPOINT, classname)
  File "/opt/minemeld/engine/core/minemeld/loader.py", line 136, in load
    return mmep.ep.load()
  File "/opt/minemeld/engine/current/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2322, in load
    return self.resolve()
  File "/opt/minemeld/engine/current/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2328, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/opt/minemeld/local/library/537b327d-0f93-4564-88c4-9dbbda03fe1a/vinamrataxii/node.py", line 53, in <module>
    from . import basepoller
ImportError: cannot import name basepoller

Any ideas?

L1 Bithead

Re: error activating extension

So because i copy pasted the whole code from taxii.py there were few imports that was from . and this is an extention so . didint reference properly.

 

i changed the imports to use proper class names and it worked like a charm.

 

 

Thanks

Vinamra

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!