Receiving error when running ansible panos_static_route module

Reply
Highlighted
L0 Member

Receiving error when running ansible panos_static_route module

Hi Guys,

 

stuck here, running the static route module and receive this error:

 

ERROR! couldn't resolve module/action 'panos_static_route'. This often indicates a misspelling, missing collection, or incorrect module path.

 

This should work as my other modules panos_object / panos_security_rule all work. 

 

Highlighted
L4 Transporter

Re: Receiving error when running ansible panos_static_route module

panos_static_route exists both in the Palo Alto Networks role and the collection.  The only place it doesn't exist is (most likely) in upstream ansible/Ansible.  So I suspect that you're not using either the role or the collection.  Make sure you've installed the collection (or the role if you're Ansible 2.8 or lower) and are properly invoking it in your playbooks.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!