XQL Query for calculating XDR log ingestion

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

XQL Query for calculating XDR log ingestion

L4 Transporter

Hi, 
As this is covered by the XDR license and not visible in the data ingestion widgets..

Does anyone have a query to look at data ingestion for XDR agents only?

 

thanks in adv

5 REPLIES 5

L3 Networker

Hi,

 

Thanks for reaching out LC.

 

You can use the below query example below and filter by the product you want to view:

 

dataset = metrics_source
| fields _vendor , _product , total_size_bytes , total_size_rate
| comp sum(total_size_bytes ) as ingestion by _product
| alter Ingestion_by_MB = divide(round(multiply(divide(ingestion , pow(2,20)),10000)),10000)
| fields _product ,Ingestion_by_MB
| sort desc Ingestion_by_MB

 

Regards.

 

If you feel this answered your inquiry please mark As Solution.

Visit our Cortex XDR Customer Corner on Live Community to access resources for your product journey, engage in discussions with community members and subject matter experts, and register for upcoming events: Cortex XDR Customer Corner

L4 Transporter

Thanks Mavega

..that does work.. but, it shows the metrics for xdrc - the xdr collector only. not xdr agents.

 

any ideas?

thanks

L2 Linker

I'm not aware of any log size's metrics for endpoints, but being familiar with the log counts per xdr agent should bring you closer to your goal  

dataset = xdr_data 
| filter   _product = "XDR agent"
| comp count() as logs by agent_id , agent_hostname 
| sort desc logs

 

dataset = metrics_source

|comp sum (total_size_bytes) as gunluk_total_bytes by _product //

|alter gunluk_ortalama_log_boyut_kb=divide (gunluk_total_bytes ,1024) //KB
|alter gunluk_ortalama_log_boyut_mb=divide (gunluk_ortalama_log_boyut_kb ,1024) //MB
|alter gunluk_ortalama_log_boyut_gb=divide (gunluk_ortalama_log_boyut_mb ,1024) // GB


you can use this query

L1 Bithead

By the way How can we write an XQL query to calculate the total log volume for the last 24 hours in GB and check whether it is 20% higher than the previous day?

  • 1761 Views
  • 5 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!