Our experience with traps. Unfortunately very bad!!!

Showing results for 
Search instead for 
Did you mean: 

Our experience with traps. Unfortunately very bad!!!

L1 Bithead

We ordered Traps because we had a very good experience with the Palaoalto Firewall's and the features of Traps sound good. We installed the ESM server, uninstalled our previous soloution (Trend Micro Worry-Free Business Soloution) and rollout the Traps client. Everything worked well. But with the first update came the problems. The update sometimes not work, the Traps service were missing or not started. We must reinstall clients manually often with the removal tool. With each update always the same problems!
Then we heard from the Traps management service. In the hope that the problems do not occur with the Traps management service we migrated our configuration. Everthing works well again. But with the first update the same trouble.
We order Traps from our dealer. It's a business partner from Paloalto. And therefore we can't open a support case directly by Paloalto. Two weeks ago our dealer told us it's a bug and it would be solved with the agent version 5.0.4. But we have the same problems with 5.0.4. Our dealer has never been able to help us but always want money for his support.

Has anyone had the same experiences?


L1 Bithead

With the January release and the client 5.0.5 seems the problems where be solved. Now I wonder why no one else had the same problems?

L1 Bithead

sorry for asking: if i understand correctly you have installed the "on-premises" ESM server, which is still at 4.2.2 version.

Are you using it with 5.x agent version? Is it possible/supported?

I'm still with the on-prem ESM solution, but i still deploy agents in the same version the esm is.

No, we using since last year the Traps Management Service instead "on-premises" ESM server

oh i see.

honestly, i have updated many times che ESM and never had a single issue other than the impossobility to uninstall with from the client using the pass

L2 Linker



The uninstall password and change uninstall password are bug since traps 4.1.2 if I remember well, Thast´s looks like in the version 4.2 that will fixed, according your experience it's not. Anyway, one solution for tat issue (temporary until the bug is fixed) is:
1. Open a cmd console with administrator rights
2. move to path where your installer 
3. run the command: msiexec /accepeula /x Path\Traps_x64_4.1.1.28779.msi UNINSTALL_PASSWORD=Password1 /l*v c:\uninstallLogFile.txt


NOTE: By default the uninstall password is: Password1.

Using a Uninstall Policy with Password1 wolud works fine.


The version 5.x its not the same that 4.x, from the behavior to the policies, all are different, the protection is different too.

I use both, ESM based for all mi internal clients and  TMS for movil users, some linux and MAC.

For my personal use (for me only) the upgrade of all clients (using ESM) I prefer make it computer to computer, because one latency on the network, computer freeze, hibernation, laptop close or whatever thing could stop the installation/unistallation/upgrade and damage the agent.


I hope that help to you.




Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!