Can't install Expedition

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't install Expedition

L0 Member

Im trying to install expedition on an ubuntu server with no luck. It seems it can't find the required dependencies. Any help would be greatly appreciated.


Fetched 325 kB in 1s (186 kB/s)
Reading package lists... Done
W: The repository ' expedition-updates/ Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@server:/etc/apt/sources.list.d# sudo apt-get install expedition-beta
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package expedition-beta


L2 Linker


sudo apt-get install expeditionml-dependencies-beta

Let me recommend switching the order of installs:

sudo apt-get install expeditionml-dependencies-beta

The first time it ran that was my order, but it failed on the dependencies. 


I ran it the second time with the dependencies first and it was successful. 

expedition-dependencies-beta actually is defined to require expedition-beta, as it needs configuration files that are installed with the expedition-beta package.

Then have someone fix the expedition-beta install package? I ran it after upgrading expedition from 1.1.28 or 1.1.29 and running it afterward fixed the remediation error in the web gui. I will go through the package to see where it is failing when I have time, but we haven't had much time to use Expedition as of late. 


Remediation: Execute the following command in CLI : sudo apt-get install expeditionml-dependencies-beta


I rolled back the machine to an earlier version to get the error I received. 



Setting up expeditionml-dependencies-beta (0.1.1) ...
Allow firewall ports for reporting
sudo firewall-cmd --permanent --add-port=5140-5150/tcp
sudo: /usr/bin/firewall-cmd: command not found
sudo firewall-cmd --permanent --add-port=4060-4070/tcp
sudo: /usr/bin/firewall-cmd: command not found
sudo: firewall-cmd: command not found
/var/lib/dpkg/info/expeditionml-dependencies-beta.postinst: line 9: /opt/Spark/postScripts/ No such file or directory
/var/lib/dpkg/info/expeditionml-dependencies-beta.postinst: line 10: /opt/Spark/postScripts/ No such file or directory
dpkg: error processing package expeditionml-dependencies-beta (--configure):
subprocess installed post-installation script returned error exit status 127
Setting up expedition-beta (1.1.38) ...
Checking for old projects and Devices what are not Encrypted
sudo: /usr/bin/firewall-cmd: command not found
sudo: /usr/bin/firewall-cmd: command not found
cp: cannot create regular file '/opt/Spark/': No such file or directory
its recommended to run after install: apt-get -y -f install
its recommended to run after install: sudo apt-get autoremove
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)




The error you are displaying is precisely what I mentioned.


You require having installed expedition-beta first so the files are present for configuration of expediitionml-dependencies-beta package.

There should not be issues installing expedition-beta, through the installer. We tested recently and the servers are available.

  • 6 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!