Expedition csv logs stuck in pending

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Expedition csv logs stuck in pending

L1 Bithead

Hi everyone,

I have added firewall logs from our Palo Alto 5000 series to the Expedition VM /PALogs . I have copied the orginal .csv as a duplicate with root as the owner and the original with expedition as the owner. Both files appear in Devices > M.LEARNING. When I run Process Files the job remains in pending and nothing happens. Any ideas what the issue may be?

Screen Shot 2018-06-26 at 10.35.44 AM.png
Screen Shot 2018-06-26 at 10.37.27 AM.pngScreen Shot 2018-06-26 at 10.36.50 AM.png


L2 Linker

Most likely the webserver does not have permission - specifically for one owned by root.


Try this from root dir


sudo chown -R www-data:www-data PALogs/

Ok so I tried running:

sudo chown -R www-data:www-data PALogs/

Screen Shot 2018-06-26 at 12.18.09 PM.png

Screen Shot 2018-06-26 at 12.20.55 PM.png

Unfortunatley the job is still in pending and not procesing. any other thoughts?

Thanks for the assistance.

Where is your machine learning path set up and does www-data have proper permissions in that folder to output the files after they have been processed?

This is what I have configured for the machine learning paths:

Screen Shot 2018-06-26 at 12.58.37 PM.pngScreen Shot 2018-06-26 at 12.58.09 PM.pngScreen Shot 2018-06-26 at 12.57.52 PM.png

That looks good.


Just thinking outloud and giving a few possible solutions:


Run these:


sudo apt -o "Acquire::AllowInsecureRepositories=true" -o "Acquire::AllowDowngradeToInsecureRepositories=true" update
sudo apt upgrade
sudo apt upgrade
Then edit /etc/php/7.0/apache2/php.ini
line mysqli.reconnect = off (change to on)
Then edit /etc/php/7.0/cli/php.ini
line mysqli.reconnect = off (change to on)
sudo service apache2 restart
sudo php /var/www/html/bin/updates/updateSQL.php

Thanks again for all of your help. I tried the suggestions you made and was still unable to process the csv. It remains on pending, I've also tried to remove the process and start over again but yield the same results.


Then try to export that csv and see if it is valid log export, maybe it got corrupted in the process and expedition does tell you that. 

Ok so I re-exported the csv then scp'd it over to expedition, still no luck. I then deleted the vm and re-downloaded and re-setup a new vm, same issue. Maybe there is a bug in the newest release?

After executing this 

sudo chown -R www-data:www-data PALogs/ 

My firewalls no longer have permission to SCP log files to Expedition.  


What should the overall  permissions be for the logs folder?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!