Remediation for BPA

cancel
Showing results for 
Search instead for 
Did you mean: 

Remediation for BPA

I have no BPA version listed in Expedition under release info and the error message below in "Expedition internal checks".  I've run the shell script as suggested which appears to complete.  I've tried restarting apache and rebooting the box then clicking remediate button but nothing changes.  Not sure if it matters but I used the migration tool to move data after doing a fresh install of Expedition on Ubuntu 20.04 and tried to resolve this BPA issue after.

 

Output from end of shell script:

Installing collected packages: matplotlib, BPA
Attempting uninstall: matplotlib
Found existing installation: matplotlib 3.5.1
Uninstalling matplotlib-3.5.1:
Successfully uninstalled matplotlib-3.5.1
Attempting uninstall: BPA
Found existing installation: BPA 3.33.0
Uninstalling BPA-3.33.0:
Successfully uninstalled BPA-3.33.0
Successfully installed BPA-3.33.0 matplotlib-3.2.2

 

Message in WebUI:

Verify that Python Software Dependencies have been installed.

 

The following dependencies for ML are missing : BPA (3.33.0)
Remediation: Execute the following command in CLI:
sh /var/www/html/OS/BPA/updateBPA306.sh;

4 REPLIES 4

L5 Sessionator

If you are not using BPA , you can ignore the error message on the dashboard. If you need BPA, I would suggest you reinstall a new ubuntu 20.x VM and re-run the installation script without issue any "sudo apt-get upgrade" , it should solve the issue. 

Hi Lychiang,

 

I've tried to reinstall Ubuntu 20.04.04 several times (without issue any "sudo apt-get upgrade" )

Add tagand run the shell script as suggested "sh /var/www/html/OS/BPA/updateBPA306.sh; " but unfortunately it didn't remediate "The following dependencies for ML are missing : BPA (3.33.0) issue"
"

WARNING: No metadata found in /usr/local/lib/python3.8/dist-packages
Rolling back uninstall of pillow
Moving to /usr/local/lib/python3.8/dist-packages/PIL/
from /usr/local/lib/python3.8/dist-packages/~IL
Moving to /usr/local/lib/python3.8/dist-packages/Pillow-9.1.0.dist-info/
from /usr/local/lib/python3.8/dist-packages/~illow-9.1.0.dist-info
Moving to /usr/local/lib/python3.8/dist-packages/Pillow.libs/
from /usr/local/lib/python3.8/dist-packages/~illow.libs
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> Pillow

note: This is an issue with the package mentioned above, not pip.
hint: See above for output from the failure."

 

 

Any suggestion please ? 

Thanks so much Lychiang - it works as a charm 🙂

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!