COMMIT FAILED: Unknown node class

Showing results for 
Show  only  | Search instead for 
Did you mean: 

COMMIT FAILED: Unknown node class

Hi All,


I have old instance of Minemeld (0.9.52) running on Ubuntu 14.04. I am planning to migrate it to new server and upgrade it, but it will take some time. Meanwhile I need to mine the Azure Cloud IPs for specific service. But my instance is still using the old azure prototype, which is mining the depicated XML file and not the JSON file with service tag.


I have tried to manually update the prototype, but when I try to use the miner I am receiving error:

COMMIT FAILED: Unknown node class in azurecloudIPs-miner


What I did was:

1. Copied the latest from the git repo and replace it current one

$ sudo -u minemeld cp /opt/minemeld/engine/0.9.52.post1/lib/python2.7/site-packages/minemeld/ft/ /opt/minemeld/engine/0.9.52.post1/lib/python2.7/site-packages/minemeld/ft/
$ sudo -u minemeld vim /opt/minemeld/engine/0.9.52.post1/lib/python2.7/site-packages/minemeld/ft/
copy-pasted the whole content form github


2. Copied the latest azure.yml prototype from Github and put it as local prototype

$ sudo -u minemeld cp azure.yml /opt/minemeld/local/prototypes/localazure.yml


3. Created miner using the prototype localazure.cloudIPsWithServiceTags. But when I try to commit I am receiving error message that the class is unknown


I have found few old post with same error message, suggesting to update nodes.json and run pip install command, but both of them are not present in my instance


I also tried to copy the nodes.json from github and put it in /opt/minemeld/engine/current/, but still not luck

I am guessing the key step here should be the
$ sudo -u minemeld /opt/minemeld/engine/current/bin/pip install -e /opt/minemeled/engine/core/"
but there is no core directoty in my instance and the pip command is failing.



Any help is appreciated!

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!