Execution error on a playbook solved with job

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Execution error on a playbook solved with job

L0 Member

Hi all,
I am using XSOAR 6.10.0
Activity I am performing:
Running a playbook (consisting of 3 tasks):
1) task that invokes an automation that from an API call generates the response in CSV format.
2) Send-mail task, from the attachIDs and attachNames of the CSV file generated by the previous task sends it as an attachment to the email.
3) Closes the incident
Problem: To test the execution of this playbook I run RUN on the playbook in edit mode, however I encounter several errors such as:
- during the execution of the send-mail task (see screenshot 1):
Command:
!send-mail "correct send-mail values"
Reason
Entry 461@53232f297a57a5a743894a0e4a801fc3$&$85faa662-59da-4428-814d-2298b3b1b553 is not valid or is not a file entry
Traceback (most recent call last):
File "<Mail Sender (New)>", line 149, in collect_attachments
File "<string>", line 93, in getFilePath
File "<string>", line 283, in __do
ValueError: failed to get artifact file path, invalid file (52)
- during the execution of the first task, the file is generated with a size of 0 bytes and of course the send mail task generates an error reading the file (see screenshot 2).
All this is solved by running the playbook from a job.
NB: If I run the automation command from WarRoom it is executed correctly.
I would like to kindly know the reason for this issue. Why can't I run these execution tasks directly in the playbook instead of having it run from a job?

1 REPLY 1

Cyber Elite
Cyber Elite

@MF762,

Might be better to open a support ticket on this one honestly. If I'd hazard a guess the temporary storage location that you're using when in the playbook editor can't write files where saved and running as a job on your dedicated resources it can write the file(s) properly. 

  • 949 Views
  • 1 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!