Failed to renew device certificate

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Failed to renew device certificate

L3 Networker



the device certificate is going to expire end of march.

My PA trys to renew it and comes up with the following error:

Failed to renew device certificate.Failed to send request to CSP server.Error: No OCSP response received(dest =>


I have no telemetry enabled.

Just activated the certificate with OTP on 2020/12/29 after upgrading to PanOS 9.1.7.


Now it´s the first try of my PA to renew it.


The only thing i found relates to PanOS 9.1.8 wich seems to fix another error with device certificate:

Fixed an issue where the firewall returned the following error message when attempting to request a device certificate using a one-time password (OTP): 

invalid ocsp response sig-alg


Any ideas where to look for?




L0 Member

Have you checked your conectivity to

I've just installed a new certificate for a Panorama, worked ok.

Last traffic to ( url eq '' ) was on 12/29 when the certificate was installed the first time.

No block / deny or other traffic to this url or ip since then.


Seems the PA ist trying to connect to and there is no deny for it.

The mgmt interface has an allow rule but the renew is not working.

This was the traffic from the last 2 days to




The Root CA Palo Alto Networks Inc.-Root-CA G1 that signed the cert for

is not trusted if you browse to the url. But that should not be the problem.


I have exactly same problem on many devices in different configurations. Nothing is blocked, DNS resolves OK.

L3 Networker

Today i requested a new OTP and choose to Get Certificate on the PA which revokes the actual cert and requests a new one.

The new Cert request finished without problems.

Now i wait til 16-06 to see if the next renew will work automatically or if the problem comes up again.

same problem here, i also renew the certificates using one-time password.


L1 Bithead

allow app 'paloalto-shared-services' to mgmt console rule, your most likely getting blocked. I was

Thanks, this is what helped me with getting the device cert installed on a couple of new firewalls.

My cert expires in 31 days and I see no way to renew it.  I don't have a way to track the firewalls attempts since this happens via the mgmt interface.  All I see is the graphic below and it doesn't look like it's tried to connect to the server since the cert was issued.  


How do I renew it?




PCNSE, PCNSC, CyberForce

The Palo normally fetches a new cert by itself before the other expires. There should be no need to get it manually under normal conditions.

I see a link with get certificate wich i used the last time (see my older posting from 2021-03-18).




I have no such link.




PCNSE, PCNSC, CyberForce

Community Team Member

Hi @Jason_Lieberman ,


There's a way to fetch it using the CLI:

admin@PA-LAB> request certificate fetch otp <value>


replace <value> with the OTP generated on the support portal.


Hope this helps,


LIVEcommunity team member, CISSP
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

While the 'request certificate fetch otp' is not a valid command on my 440.  'request certificate fetch' is.  When I ran that is managed to get a new cert.  I'm shocked!  It's been failing for a few weeks now and TAC is stumped as to why.


Thank you for that.

PCNSE, PCNSC, CyberForce

Try the solution here on the 440 - it works luckily :

Then ssh in and try simply:

 request certificate fetch


  • 15 replies
  • 101 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!