Global Protect client silent configuration

cancel
Showing results for 
Search instead for 
Did you mean: 

Global Protect client silent configuration

L1 Bithead

Hello everybody,

I have to distribute global plotect client to 200 notebook. I have successfully tried using GPO. The question is:

How can I prevent manual insert username, password and portal address on 200 notebooks the first time?

Thanks for the advice.

Daniele

10 REPLIES 10

L4 Transporter

Hi,

Assuming all notebook computers are in AD domain, you can deploy a registry key "Portal" under HKEY_LOCAL_MACHINE\Software\Palo Alto Networks\GlobalProtect\PanSetup with your portal hostname in it.

When you choose single sign-on as instead of on-demand as the mode of GP client, we will use Windows credential to transparent auth the client with the portal.

So now everything will be transparent.

Hi and thanks for the advice.

Another thing ...

When I try to switch between two connection (the first with internal network cable and the second with a UMTS connect card for testing internl and external gateways) many times the program ask me to enter the Gateway password. Why?

I have installed Kaspersky Antivirus on computers and I just create the exclusions (otherwise nothing work!). Any idea?

Thanks

Daniele.

Hi,

It is because you are creating the SSL VPN tunnel from two different IP addresses during the switch. Will you see the same problem if you choose to save the password?

Antivirus may think our process is malware and so sometimes you need to exclude it from scanning.

In Windows 7 64bit is not possible to set the gateway address from registry. Anyone know the solution?

If i understand you dont see the HKEY_LOCAL_MACHINE\Software\Palo Alto Networks\GlobalProtect\PanSetup in Win64 bit? Did you install GP agent on the host and see if you see the registry key?

I've installed the GP, create the registry key and reboot the system. When open PA I can't see the portal address. this appened only in 64bit system. In 32bit system all works good!

L0 Member

Does anyone have an update on this?  I also have the issue with 64bit clients

Not for me. Only on 32bit system the registry key function.

L4 Transporter

Have you tried searching the entire registry for the keys in question?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!