GP 4.1.0 released and....
cancel
Showing results for 
Search instead for 
Did you mean: 

GP 4.1.0 released and....

L4 Transporter

I have not seen any chatter or mention of this but I tried the 4.1.0 GP client in a lab environment yesterday.

 

The good:

* The app is redesigned and looks really nice

* You can now select from/add/remove multiple gateways!

 

The bad:

* It would not connect to the VPN even after a reboot and reinstall :/

 

After going back to 4.0.7 everything worked again, then trying 4.1.0 again and same thing (no connection) then back to 4.0.7 and yay! working again. I see the traffic coming into the portal and being allowed, the client just never gets an established connection.

 

Anyone else brave enough to play with the new GP client? What did you find? Did it work? Same issue I am seeing?

 

Whats next:

I will try the new client on some other machines and OS versions to see if I can isolate the issue to a certain root cause. We won't be using this in production for a while or at least until I can validate this issue will not happen if we update all endpoints someday.

 

33 REPLIES 33

@CaviumKeith,

Linux agent is still technically in Beta. I would expect issues to persist within the Linux agent for a while yet. 

@BPry @CaviumKeith

 

I was able to get a good connection with the Linux client but it is susceptible to the same password character and spaces bug. Also while it does work for me in Ubuntu I could not get it to work in the other distro I tested in and I think it has to do with certificates and where they are stored/how they are imported/etc

L4 Transporter

4.1.1 is out today and addresses several issues that were reported including the username/password lengths and special characters. We have tested and are able to get successful connections using spaces and long passwords.

 

We encountered the following issues with 4.1.0 that have been addressed in 4.1.1

 

Fixed an issue on MacOS endpoints where the GlobalProtect app couldn't detect processes that had more than 16 characters in their names.

 

Fixed an issue where end users who had special characters associated with XML markup (<, >, &, ', ") in their password couldn't connect to the GlobalProtect gateway after an upgrade to GlobalProtect app 4.1.0.

 

Fixed an issue where the GlobalProtect login prompt allowed only 24 characters for usernames and 21 characters for passwords. With this fix, you can enter up to 256 characters for usernames and passwords.

 

Fixed an issue on Windows endpoints where users couldn’t upgrade the GlobalProtect app using the Windows Installer (Msiexec) because the GlobalProtect setup file couldn’t overwrite existing GlobalProtect app software packages when the GlobalProtect service (PanGPS) was running.

Testing 4.1.1 now.  Waiting on PAN-OS 8.1.1 before upgrading to get the Linux Client features we're looking for.

 

Thanks,

 

Keith

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!