Interface goes Down when speed set to 1000!

Showing results for 
Search instead for 
Did you mean: 

Interface goes Down when speed set to 1000!

L2 Linker


I was getting complains for slow download speed, so I tried to change the speed setting on interface from auto to 1000, but the interface went down.

Link status:

  Runtime link speed/duplex/state: unknown/unknown/down

  Configured link speed/duplex/state: 1000/auto/up  

when I set it back to auto, it goes half duplex and speed 100

Link status:

  Runtime link speed/duplex/state: 100/half/up

  Configured link speed/duplex/state: auto/auto/up




L3 Networker

How is the other side of the link configured?

L6 Presenter


There should be issue with other end of interface configuration. It should have been configured in 100/Half.

You should hard code other end with 1000/Full just like this one.


Hardik Shah

L2 Linker

the other side in one interface is 100/full duplex and the other 1000/full duplex

Try to configure both in 1000/Full and see behavior.

Any incompatibility can cause in-consistent results.


Hardik Shah

For more information on 802.3 specifications, refer to the following: IEEE-SA -IEEE Get 802 Program - 802.3: Ethernet

Cannot Commit when Interfaces are Set to 1000/full

Autonegotiation is a requirement for using 1000BASE-T[11] according to Section 28D.5 Extensions required for Clause40 (1000BASE-T).[12] At least the clock source has to be negotiated, as one endpoint must be master and the other endpoint must be slave.

L2 Linker

in one side is the Cisco switch with this config:


interface FastEthernet0/2

switchport mode trunk

speed 100

duplex full

spanning-tree portfast trunk

ip dhcp snooping trust


on the other side PAN has this config:

X@PA-500> show interface ethernet1/4

Link status:

  Runtime link speed/duplex/state: 100/half/up

  Configured link speed/duplex/state: auto/full/up

even though it is configured to full duplex, it goes to half.

The far end is only a FastEthernet (100) interface - so you won't be able to set the PA to 1000.

Just force the PA to 100 / full duplex and you'll be fine.

Yes that interface is connected to FastEthernet, but the other one was in GigabyteEthernet.

However the problem with half duplex was because the interface was in VWire and in order to work in fullduplex both VWire interfaces had to be configured for fullduplex. It is strange though that Link Duplex Auto goes to Half by default.

thanks everyone for comments and suggestions.

Well, you had the Cisco forced to 100/full.  This doesn't force the negotiation to 100/full - but instead turns negotiation off altogether.  Your PA tried negotiating; couldn't get anything back from the other end and (rather stupidly really) guessed half duplex.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!