Microsoft Store app error message not online when connected to Pre-Logon Global protect
cancel
Showing results for 
Search instead for 
Did you mean: 

Microsoft Store app error message not online when connected to Pre-Logon Global protect

L0 Member

Hello everyone,

 

I am connected to Global protect Pre-Logon and when I am trying to download "Microsoft Wireless Display Adapter" using Microsoft.com URL, it prompt to use Microsoft Store App to download that software and but when I click to proceed with opening Microsoft Store the error window comes up and saying Microsoft store is not online and asking to check connection however global protect is connected via same internet connection and I can browse other websites.

 

Has anyone been across this issue or any lead how we can access Microsoft store via Global Protect? 

 

Thanks

5 REPLIES 5

L7 Applicator

firstly have you tried to modify VPN adapter by selecting "client for microsoft networks".

 

if this does not help then try the following,,

 

Go to: Control Panel\Network and Internet\Network Connections

Right-click the TAP network device for your VPN.
Go to properties.
Click Configure.
click the Advanced tab

Select "Media Status"
Change Value to "Always connected"
Click ok.

Right-click the TAP network device for your VPN again.
Go to properties.
Click "internet services version 4 (TCP/IPv4)"
Click Properties.
Click Advanced.
Tick the "Automatic Metric" boxClick ok.

Click ok.
Click Close.

 

reconnect VPN and try the MS store.

How would you push this always connected setting from an enterprise domain?

@Paul.Allen,

If you are running into an issue where Microsoft Store applications (UWP or the actual Store app itself) aren't working while connected to GlobalProtect this is likely an NLA issue. You can fix this via Group Policy https://docs.microsoft.com/en-us/troubleshoot/windows-client/shell-experience/microsoft-store-not-op...

@BPry Thanks for your notes. I'll try that if we run into an issue again. In the meantime, this immediate issue was resolved with just the first part of his solution notes, and we figured out how to make this change to all users with Powershell with the following two commands (detection, and action).

(Get-NetAdapterAdvancedProperty -InterfaceDescription 'PANGP Virtual Ethernet Adapter' -DisplayName 'Media Status').DisplayValue

Set-NetAdapterAdvancedProperty -InterfaceDescription 'PANGP Virtual Ethernet Adapter' -DisplayName 'Media Status' -DisplayValue 'Always Connected'

Thanks for the advice, it helped me solve the problem!

Hey! I am the person who is always ready to help you, text me here at any time. I work as a writer and help students write college essays. My specialty is law. I love my job and the fact that I can help students make their college life easier.
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!