New minemeld deploy unable to login to GUI

Showing results for 
Show  only  | Search instead for 
Did you mean: 

New minemeld deploy unable to login to GUI

L4 Transporter

Used OVA to deploy it on ESXi.  Default admin/minemeld did not work after deployment and NO changes.  Gives the message "ERROR CHECKING CREDENTIALS: Bad Gateway"


Logged in via CLI and ran the following:

ubuntu@minemeld:~$ sudo htpasswd /opt/minemeld/local/config/api/wsgi.htpasswd admin
New password:
Re-type new password:
Updating password for user admin

ubuntu@minemeld:~$ sudo -u minemeld /opt/minemeld/engine/current/bin/supervisorctl -c /opt/minemeld/supervisor/config/supervisord.conf restart minemeld-web
minemeld-web: stopped
minemeld-web: ERROR (abnormal termination)

Still cant login after changing the password.  


That number of indicators is pretty small. Is RabbitMQ taking so much memory?

Here's the current usage:


ubuntu@minemeld:~$ ps auwx |grep -v grep | grep rabbitmq
rabbitmq 22283  0.0  0.0   7500   312 ?        S    Aug10   0:03 /usr/lib/erlang/erts-5.10.4/bin/epmd -daemon
rabbitmq 22304  0.0  0.0   4444   648 ?        S    Aug10   0:00 /bin/sh /usr/sbin/rabbitmq-server
rabbitmq 22310  0.3  7.7 756584 159268 ?       Sl   Aug10  28:24 /usr/lib/erlang/erts-5.10.4/bin/beam -W w -K true -A30 -P 1048576 -- -root /usr/lib/erlang -progname erl -- -home /var/lib/rabbitmq -- -pa /usr/lib/rabbitmq/lib/rabbitmq_server-3.2.4/sbin/../ebin -noshell -noinput -s rabbit boot -sname rabbit@minemeld -boot start_sasl -kernel inet_default_connect_options [{nodelay,true}] -sasl errlog_type error -sasl sasl_error_logger false -rabbit error_logger {file,"/var/log/rabbitmq/rabbit@minemeld.log"} -rabbit sasl_error_logger {file,"/var/log/rabbitmq/rabbit@minemeld-sasl.log"} -rabbit enabled_plugins_file "/etc/rabbitmq/enabled_plugins" -rabbit plugins_dir "/usr/lib/rabbitmq/lib/rabbitmq_server-3.2.4/sbin/../plugins" -rabbit plugins_expand_dir "/var/lib/rabbitmq/mnesia/rabbit@minemeld-plugins-expand" -os_mon start_cpu_sup false -os_mon start_disksup false -os_mon start_memsup false -mnesia dir "/var/lib/rabbitmq/mnesia/rabbit@minemeld"
rabbitmq 22424  0.0  0.0   7464   428 ?        Ss   Aug10   0:00 inet_gethost 4
rabbitmq 22425  0.0  0.0   9556   656 ?        S    Aug10   0:00 inet_gethost 4

Couldnt log in with default creds of admin/minemeld. This worked for me after a fresh install ansible style on ubuntu 18.04. 


 I Followed:

$ sudo apt update
$ sudo apt upgrade
$ sudo apt install -y gcc git python-minimal python2.7-dev libffi-dev libssl-dev make
$ wget
$ sudo -H python
$ sudo -H pip install ansible
$ git clone
$ cd minemeld-ansible
$ ansible-playbook -K -i, local.yml
$ usermod -a -G minemeld <your user> # add your user to minemeld group, useful for development


I tried this fix as noted by drewdown and it works! 


sudo service minemeld stop
sudo -H -u minemeld /opt/minemeld/engine/current/bin/pip install pip==9.0.3
sudo service minemeld start


I have tried the following commands and no change:

sudo service minemeld stop
sudo -H -u minemeld /opt/minemeld/engine/current/bin/pip install pip==9.0.3
sudo service minemeld start

Any suggestions?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!