On-demand GlobalProtect and Mapped drives

Reply
Highlighted
L2 Linker

On-demand GlobalProtect and Mapped drives

Hello all ,

 

Having issues with some users where they have mapped drives but after they connect to global protect they don't work.

 

If they unmap and they map again it works .

When doesn't work after connecting to globalprotect if they ping the IP of the server that they have the mapped drive it works but SMB it doesn't .

 

 

We have on-demand globalprotect, SSO disabled of course and we allow netbios, SMB and I don't see any blocked traffic.

I have tried to search that and I don't want to say to the customer to fix that with scripts net use because all users are using their own shared folders.

 

 

Highlighted
L7 Applicator

Re: On-demand GlobalProtect and Mapped drives

@GeorgiosFakis,

What version of Windows are they using? Does the drive show as disconnected and simply won't connect, or does it simply hang when they try to access the drive? If the user restarts explorer.exe after they connect to GlobalProtect can they access the drive? 

 

I'd also ensure that the group policy you are using to map these drives is set to Update instead of Replace. There was an instance a while back where the Group Policy updating in the background with a Replace action would cause the drive mapping to be lost like you are describing here. 

L2 Linker

Re: On-demand GlobalProtect and Mapped drives

Hi ,

 

Users most of them have Windows 10 and they show disconnected .We have not tried to restart this service but what we have tried to access through run command \\shareX\ .

 

We don't have standard mapped drives, each user adds their own for their work.

Highlighted
L7 Applicator

Re: On-demand GlobalProtect and Mapped drives

@GeorgiosFakis,

When someone runs into this again, try restarting explorer.exe and see if you are able to access the mapped drive again. 

Highlighted
L2 Linker

Re: On-demand GlobalProtect and Mapped drives

Hi,

 

We tried with one user and didn't work but you know what they say? Pulse Secure was not causing that issues .

 

I have isolated the issue to specific shared folders. All common shared folders they are connected after user connect to global protect.I have asked the server team to check as well these specific shared folders and from what it seems is the sync between host and AD.

Highlighted
L0 Member

Re: On-demand GlobalProtect and Mapped drives

I am having the exact same issue but mine is "well Sonic Firewall works". Makes it hard to sell a new VPN solution to management when things like this don't work.
Highlighted
L0 Member

Re: On-demand GlobalProtect and Mapped drives

So I want to share that I believe we have found the solution for mapping our personal drives without having to have the pre-logon. I had one of my admins create a .vbs file that will pull the home drive mapping info from AD. then we added a registry key into the install package to point to the .vbs file to execute this post-vpn-connect. https://docs.paloaltonetworks.com/globalprotect/7-1/globalprotect-admin/set-up-the-globalprotect-inf...
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!