PAN-OS 10.0.5 is out: Issues upgrading Panorama

Announcements

Changes to the LIVEcommunity experience are coming soon... Here's what you need to know.

Reply
Neuffer
L1 Bithead

PAN-OS 10.0.5 is out: Issues upgrading Panorama

I am trying to upgrade a panorama from 10.0.4 to 10.0.5. I see the following error message:

panorama-1> request system software install version 
  10.0.0   10.0.0
  10.0.3   10.0.3
  10.0.4   10.0.4
  10.0.5   10.0.5
    Upgrade to a software package by version

panorama-1> request system software install version 10.0.5 
Executing this command will install a new version of software. It will not take effect until system is restarted. Downgrading from PAN-OS 9.0 to an earlier release requires downgrading the logging infrastructure. After downgrade, you must migrate your log data to the previous format. For more information, please refer to Downgrade from Panorama 9.0 in https://docs.paloaltonetworks.com/downgrade-panorama. Do you want to continue? (y or n) 

Software install job enqueued with jobid 2717. Run 'show jobs id 2717' to monitor its status. Please reboot the device after the installation is done.
2717

panorama-1> show jobs id 2717

Enqueued              Dequeued           ID                              Type                         Status Result Completed 
------------------------------------------------------------------------------------------------------------------------------
2021/03/26 11:24:34   11:24:34         2717                         SWInstall                            FIN   FAIL 11:24:35  
Warnings:
Details:Failed to install 10.0.5 with the following errors.
SW version is 10.0.5
alab or repo.dir is None
Error: Traceback (most recent call last):
  File "/opt/panrepo/releases/10.0.5/validate", line 20, in 
    product = sys.argv[3]
IndexError: list index out of range

Failed to install   version  10.0.5  type  cms

Has someone seen the issue, too?

 

Tags (3)

Accepted Solutions
Neuffer
L1 Bithead

I am glad you asked. We just had a session with a root engineer. Something was very broken. Even a downgrade to PAN-OS 10.0.3 didn't work. At the end a reinstall of PAN-OS 10.0.4 solved the issue.

View solution in original post


All Replies
NikolayDimitrov
L4 Transporter

I admit I haven't but have you you upgraded to the latest dynamic updates before installing 10.5 and checked the disk space if it is full as I have seen many such issues because of this?

Neuffer
L1 Bithead

Disk has enough space. Latest dynamic updates are installed.

 

A python traceback because of missing command line arguments looks more like a bug. I have opened a case for this.

I'll post an update as soon as I got an update from TAC.

PeteS
L1 Bithead

Any updates and if you were successful how is Panorama 10.0.5 - any issues?    Thinking of taking the plunge.

Neuffer
L1 Bithead

I am glad you asked. We just had a session with a root engineer. Something was very broken. Even a downgrade to PAN-OS 10.0.3 didn't work. At the end a reinstall of PAN-OS 10.0.4 solved the issue.

View solution in original post

PeteS
L1 Bithead

Thanks for the fast reply - so you are back to 10.0.4 now or resolving the issue allowed you to perform the 10.0.5 upgrade?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!