"Application is already in use" commiting custom application addition

cancel
Showing results for 
Search instead for 
Did you mean: 

"Application is already in use" commiting custom application addition

L1 Bithead

Hello,

I am trying to import a few custom applications via XML files I downloaded from my PaloAlto vendor.  I did try this before with some that I found here in this forum when running PAN 3.1.  I am now on PAN 4.1 (though I may have seen this problem before I updated).  Now when I import the XML most of them say they failed to insert, but when I have finished with all of them they all appear in the custom apps filter.  However, when I commit it fails with "application <name of app> <name of app> is already in use".  I delete the one and it continues to fail until I've deleted them all, except one, which works.  The one that works is google-safe-default.  I have attached the 5 of the XML files I'm using, including the one that works..

Is this failing because something is stuck (invisibly) in the system so I can't add these new signatures successfully?  I don't know how to search via command line to see if there is anything already there.  Also, are these compatible with 4.1 anyway?

Thanks for any suggestions you may have.

Geoff

3 REPLIES 3

L5 Sessionator

Hi Geoff,

I do believe these would need to be rewritten for 4.1's app database. I went to the objects tab, then to the applications section and found there were many similar applications already there by searching for "google". I didn't find any of the safegui ones though. I'm not sure what the difference there is, but if it's an application you'd like to see in a future application database release from us you can submit it.

Direct your web browser to http://www.paloaltonetworks.com/researchcenter/submit-an-application/ and complete the form and the application will be submitted to potentially be in an upcoming release.

Thanks,

Jason

L3 Networker

You might have to take a look at the running-config in xml and search for the apps that you are trying to add. If you find them in the xml, you can delete them in there.

Thanks for the suggestion.  I just exported the running config and I believe I see the stuff in there.  I may clean that up later.  However, to get around this I had opened the 8 non-importing XML appid files and slightly changed the name near the top of the file.  I was then able to import them and commit successfully.

Geoff

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!