Unable to access Windows Store (Windows 10 + GP 3.0.2)

L6 Presenter

My answer would not help you but l have noticed that Windows 10 causing a lot of issues not just with your case.

Cyber Elite

is really no one using global protect on windows 10? :P

Cyber Elite

Personally we don't run GP at all and have chosen to just continue to use ASAs for the VPN and have the PA do everything else. The issue with GP had more to do with it not being near as user friendly as AnyConnect has been and given the choice users didn't want to switch. 

L1 Bithead


Did you solve this issue?

A customer of mine is having the same, and he pointed me to a checkpoint URL where it states that the microsoft Virtual Adaptor for the VPN tunnel is hiddent by default, and hence prevents the connection to the store.



Let me know...



Cyber Elite

Hi Jérôme


Unfortunately, now we stil haven't solve this issue. We just lowered the priority of this/had to accept that it does not work (actually our users don't really need this store on their working computers, so the problem is not that important)

I tried to adapt the checkpoint solution to the PANGB network adapter. But there the initial "characteristics" value was 81 (129 in decimal). I changed this to "1" but so far I am still not able to access the store when connected with VPN.






L1 Bithead


My customer is really unhappy....can't we boost this issue?

Additionnlly customer has just migrated to GP 4.0.2...

We've opened a ticket to support, and are awaiting answer....



Cyber Elite


This is more of a Microsoft issue than it is strictly related to GlobalProtect. 

Palo Alto Networks Guru

So what is the issue ? We have customers successfully using the Windows 10 app. Are you referring to the app on Windows Store , https://www.microsoft.com/en-us/store/p/globalprotect/9nblggh6bzl3  or the regular GlobalProtect MSI app for Windows 10 that you download from our support portal or your GlobalProtect Portal.  If you want to know the difference between store app and regular app refer to https://www.paloaltonetworks.com/documentation/71/pan-os/newfeaturesguide/globalprotect-features/glo...


The best way to resolve an issue if you are not able to find an answer in the community is to open a support case.

Cyber Elite


The problem is NOT the Global Protect app/application. We also use the application and it works great. The only issue in this topic is: Accessing the windows store while connected to a global protect gateway with routed into the tunnel.

Now how are you going to solve an issue (if its not mission critical like this one) when:

  • PaloAlto says that it is a problem of windows
  • Microsoft does not care because the store is accessible without GP or with their own VPN, so it can't be a problem of windows
Palo Alto Networks Guru

Got it. Thanks for the clarification. Will invsetigate internally so as to what's happening and update the thread.


Another quick question, is this problem only when you are using the Wndows 10 UWP GlobalProtect app ? Meaning if you use the regualr windows GlobalProtect app on a windows 10 device and have the VPN established are you able to access the Windows Store ?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!