Unable to disconnect Global Protect in Linux machine


ATTENTION Customers, All Partners and Employees: The Customer Support Portal (CSP) will be undergoing maintenance and unavailable on Saturday, November 7, 2020, from 11 am to 11 pm PST. Please read our blog for more information.

L3 Networker

Unable to disconnect Global Protect in Linux machine

Hi Team,


I have configured GP using "On demand" method when I tried to disconnect GP by ran the command (

user@linuxhost:~$globalprotect disconnect ) getting below error,
sweekrit@sweekrit-HP-240-G6-Notebook-PC:~$ globalprotect show --error
Unable to establish a new GlobalProtect connection as a GlobalProtect connection is already established from this Linux system by the same user or another user.
Before connection method was "Always ON" I tried by changing "ON Demand" method but it didn't help.
GP disconnect error.PNG
below is the configuration snapshot.
GP odemand method.PNG
When ever I tried to connect with different gateway I used to restart the machine.
Is there any way to disconnect GP on linux machine instead of rebooting the system?
I had verified all queries on community but there is no accepted solutions.
Can anyone help us here.
Sethupathi M
L7 Applicator

$globalprotect disconnect  should work as expected, have you tried adding 'sudo' or  $globalprotect disable  ?

Tom Piens - PANgurus.com
New to PAN-OS or getting ready to take the PCNSE? check out amazon.com/dp/1789956374
L2 Linker

@Sethupathi Did you manage to resolve the issue? 

I am getting the same error message and even "globalprotect disable" or "disconnect" does not work and returns the message below: 


"Unable to establish a new GlobalProtect connection as a GlobalProtect connection is already established from this Linux system by the same user or another user."


I am running the latest 5.1.2 linux app. 

L4 Transporter

Hi @Sethupathi ,


By any chance you have reconnected to portal after the config change from 'always ON' to 'On demand'. The client might have old app configuration.

L2 Linker


The config is definitely set to "on-demand". I did it lot of time, I uninstalled GlobalProtect app, ensured that all files are deleted. Then installed it again, connected to portal and everything works fine. As long as I reboot the machine, it gets back to the error message. Reinstalling fixes it until the next reboot.

L3 Networker

Hi Batd2,


This issue persist when not exiting globalprotect prompt-mode properly.


If you enter into the interaction prompt you have to quit it properly (don't use cntl+c <-- if you use cntl+c it'll stopped not quit the process will hang)

you have to kill it using of below command,

PC:~$ ps aux | grep global protect <----- verify the process
then kill it


PC:~$ globalprotect disconnect <-------- if on demand mode

PC:~$ globalprotect disable <-----------if always on mode

PC:~$ globalprotect show --details
PC:~$ globalprotect show --status


To connect use below command,

PC:~$ globalprotect connect --portal <portal ip>






Tags (1)
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!