Issues uninstalling GlobalProtect because of missing installation ?.
Showing results for 
Search instead for 
Did you mean: 

Issues uninstalling GlobalProtect because of missing installation ?.

L0 Member



I had a working version of the 64 bit Windows version of GlobalProtect installed on my secondary hard drive on my Windows 10 laptop. My hard drive completely failed recently, disappearing from Windows. GlobalProtect still showed up in the Add or Remove programs list but I could not uninstall it as it said there were files missing. I tried to install GlobalProtect on my C drive but the installer says that there is a newer version of GlobalProtect already present. I tried cleaning all registries related to GlobalProtect in HKEY_LOCAL_MACHINE and in HKEY_CURRENT_USER, removed the windows service PanGPA with sc delete PanGPA, and removed the Uninstall registry as well. I still cannot install GlobalProtect because of the same issue. Are there any other files/registries I should clean in order to delete all traces of GlobalProtect? Any help would be appreciated, I would really like to be able to get GlobalProtect running on my laptop again without having to reinstall Windows.





L0 Member

Just now I managed to resolve the issue by downloading and running the Microsoft Program Install and Uninstall troubleshooter.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!